Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't install crossover from the package, ".deb". Here is a screenshoot of it : enter image description here

Here is what I got when I was trying to install with terminal:

`young@jianyue:~$ cd /home/young/Desktop
young@jianyue:~/Desktop$ sudo dpkg -i crossover.deb
Selecting previously unselected package ia32-crossover.
(Reading database ... 127804 files and directories currently installed.)
Unpacking ia32-crossover (from crossover.deb) ...
dpkg: dependency problems prevent configuration of ia32-crossover:
 ia32-crossover depends on libc6-i386; however:
  Package libc6-i386 is not installed.
 ia32-crossover depends on ia32-libs | ia32-apt-get; however:
  Package ia32-libs is not installed.
  Package ia32-apt-get is not installed.
 ia32-crossover depends on lib32gcc1; however:
  Package lib32gcc1 is not installed.
 ia32-crossover depends on lib32nss-mdns; however:
  Package lib32nss-mdns is not installed.
 ia32-crossover depends on lib32z1; however:
  Package lib32z1 is not installed.
 ia32-crossover depends on python-glade2; however:
  Package python-glade2 is not installed.
 ia32-crossover depends on lib32asound2; however:
  Package lib32asound2 is not installed.

dpkg: error processing ia32-crossover (--install):
 dependency problems - leaving unconfigured
Processing triggers for doc-base ...
Processing 33 changed doc-base files, 1 added doc-base file...
Errors were encountered while processing:
 ia32-crossover
`
share|improve this question

2 Answers 2

up vote 0 down vote accepted

Try running this in a terminal:

sudo apt-get -f install

That should fix the dependencies :)


EDIT: If that doesn't work, try doing it manually, by doing this:

sudo dpkg -I package.deb

That will return a lot of output, but look for a line that starts with Depends:. That will contain a comma-separated list of packages it depends on, so install them all manually. For example, if you have this (I know, it's kind of ridiculous):

Depends: debconf (>= 0.5) | debconf-2.0, firefox, ia32-libs | flashplugin-installer, chromium (= 12)

First, interpret it:

  • It wants either debconf, greater than or equal to (>=) 0.5, OR (|) debconf-2.0 (any version will do, according to the package), so install either one of them
  • It wants firefox, and any version will do
  • It wants ia32-libs OR flashplugin-installer
  • It wants chromium, at exactly version 12.

Then install what it needs (notice chromium=12. That tells apt-get to fetch version 12 instead of the latest. Of course, the ubuntu repositories don't hold version 12, but you get the point):

sudo apt-get install debconf-2.0 ifrefox ia32-libs chromium=12

Then you can install your package:

sudo dpkg -i file.deb

Hope this helps!!

share|improve this answer
    
I am still getting the same error, no matter how I ran it. –  owl Nov 25 '12 at 8:16
    
This does not fix the problem. It just uninstalls crossover. –  oneself May 17 '13 at 19:51
    
@oneself, Install ia32-libs, and try that again (after re-installing crossover). If that doesn't work, pastebin the output of installing ia32-libs and comment the link here. –  MiJyn May 17 '13 at 21:21
    
@oneself, also, check my updated post, and see if it works –  MiJyn May 17 '13 at 21:34
    
It says that ia32-crossover depends on lib32asound2. However, that package is not available on my system. I'm not using a Ubuntu, but a different Debian derivative. Which might be the reason why this is not working for me. I'll remove my -1. Sorry, I've been trying to chase this down for a while. Very frustrating. –  oneself May 18 '13 at 1:09

An alternative method is to use the Generic Installer. This is a binary which you can run on your system as root, and will install crossover under /opt/cxoffice.

If you still have problems at that point run:

/opt/cxoffice/bin/cxdiag --debug

This will check all of crossover's dependencies and print out a report which shows what it can find and what is missing. If something is still missing you will need to either install it or link the .so file to the right version.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.