Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Where can I get new Aegisub? Ubuntu reps have only 2.1.9 which is VERY buggy (it doesn't support cyrillic lower case, it's unaceptable for me). I found only source, but I'm not sure, that I can do everything right. Where to get new package (at least newer)?

share|improve this question
    
As this was your first question on askubuntu: It is very helpful to other users if you mark the answer that helped you. If something went wrong, leave feedback and we will be happy to help you. Thank you! –  mrcktz Nov 30 '12 at 1:26
add comment

2 Answers

up vote 3 down vote accepted

You have two options: compile from source (which is easy if you follow the instructions) or use a precompiled package for 12.04 with your 12.10 version. In both cases you will get aegisub 3.0.1.

Install from precompiled package

On this page someone provides precompiled packages of aegisub and wxWidgets (install both packages) for Ubuntu 12.04. Despite the warning that the package is of low quality, the installation should work with Ubuntu 12.10 as well.

Compile from source

I've found step by step instructions in the aegisub forum. Please take a look at the post, the poster explains all steps.

A short version in case the link goes down:

  • Install dependencies: Open a terminal (CTRL+ALT+T) and insert the following:
    sudo apt-get install build-essential libasound2-dev libass-dev libffms2-dev libfftw3-dev libgl1-mesa-dev libglu1-mesa-dev libgtk2.0-dev libhunspell-dev liblua5.1-dev checkinstall
  • Build wxWidgets by entering the following into the terminal (line for line):
    cd ~
    wget http://sourceforge.net/projects/wxwindows/files/latest/wxWidgets-2.9.4.tar.bz2
    tar xjf wxWidgets-2.9.4.tar.bz2
    cd wxWidgets-2.9.4
    ./configure --with-opengl
    make
    sudo checkinstall
    sudo ldconfig
  • Build aegisub by entering the following into the terminal (line for line):
    cd ~
    wget http://ftp.aegisub.org/pub/releases/aegisub-3.0.1.tar.xz
    tar xJf aegisub-3.0.1.tar.xz
    cd aegisub-3.0.1/aegisub
    ./configure
    make
    sudo checkinstall
share|improve this answer
    
I installed deb, but Aegisub does not start –  charlag_khan Dec 8 '12 at 14:29
    
Is there an error message? Try to start it from a terminal (CTRL+ALT+T) with the command aegisub-3.0.1. If you installed from the precompiled packages, did you also install the wxWidgets package from here (sorry, didn't point this out in my answer)? –  mrcktz Dec 11 '12 at 11:17
add comment

when reaching the step of

cd aegisub-3.0.1/aegisub
./configure

I get the error

checking for ICU_UC... no
configure: error: Package requirements (icu-uc >= 4.8.1.1) were not met:

No package 'icu-uc' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables ICU_UC_CFLAGS
and ICU_UC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I tried to install libicu-dev or libicu48, but it gives the same error..

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.