Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have got a new Samsung Series 7 laptop with dual boot setup for Windows 8 and Ubuntu 12.10. A fine machine comparable to a Macbook Pro. The Ubuntu installation was quite a hassle, but with the help of Boot Repair finally it seemed to work. Or so I thought. Windows 8 starts fine, but if I want to start Ubuntu regularly the following Machine Check Exception error occurs, quite similar to this one

[Hardware Error] CPU 1: Machine Check Exception: 5 Bank 6
[Hardware Error] RIP !inexact! 33 <00007fab2074598a>
[Hardware Error] TSC 95b623464c ADDR fe400 MISC 3880000086
.. [similar messages for CPU 2,3 and 0] ..
[Hardware Error] Machine Check: Processor context corrupt
Kernel panic - not syncing: Fatal Machine Check
Rebooting in 30 seconds

Kernel panic does not sound good. Then it starts to reboot, and the second boot trial often works. Is it a Kernel or driver problem? The laptop has an Intel Core i7 processor. I already deactivated Hyperthreading in the BIOS, but it does not seem to help :-(

I also disabled the Execute Disable Bit (EDB) flag in the BIOS. EDB is an Intel hardware-based security feature that can help reduce system exposure to viruses and malicious code. Since I disabled it, the error did occur less frequently, but it still appears occasionally :-( It seems to be the same error as described here and here. Maybe a Samsung specific Kernel problem? A similar error also happens on a Samsung Ultrabook Series 9 (which seems to be kernel bugs 49161 and 47121).

At my Samsung Series 7, it still occurs for instance during booting on battery after "Checking battery state". Perhaps anyone else has an idea? These Kernel Panic errors are reallly annoying..

share|improve this question

According to section 15.9.1 in volume 3 of the Intel Architecture Software Developer Manual the Machine Check Exception 5 from the MSR_IA32_MCG_STATUS MSR indicates in internal parity error. After reading the manual I am not sure which specific component bank 6 refers to, so I cannot determine where this physical error has occurred.

The error message indicates that bit 57 of the Machine Check Status MSR is set indicating that the internal processor state may well be corrupted by the error condition detected and that reliable restarting of the processor may not be possible. So at this point the Kernel has no real choice apart from stopping by using a kernel panic.

As things stand, this kind of error is rare.

I am unsure why disabling the EBD can cause this issue. Perhaps it is just a co-incidence. Does this panic happen frequently with EBD enabled? Incidentally, which processor model do you have? .. to find out, use:

cat /proc/cpuinfo 
share|improve this answer
Intel(R) Core(TM) i7-3635QM CPU @ 2.40GHz. Disabling the EDB Bit helped to reduce the frequency of the error, especially during booting, but sometimes a Kernel Panic occurs after a while of using the computer if no activity is going on for a while. Not sure if the error message is exactly the same, though. Is there anything else I can do to fix it? – 0x4a6f4672 Nov 25 '12 at 20:09
I'm not entirely sure, but perhaps you could check you memory using the memtest86+ from the boot menu to just see if that is triggering this. – Colin Ian King Nov 25 '12 at 20:34
Where can I find memtest86+ ? I can not remember it is in the boot menu. Do you need to burn the bootable ISO file to CD? – 0x4a6f4672 Nov 26 '12 at 11:15
When you boot your machine hold down the shift key and if you get the timing just right you will see the GNU GRUB menu. Use cursor down to move to the "Memory test (memtest86+)" option and press enter. Let it run several tests to see if it finds a fault. – Colin Ian King Nov 26 '12 at 11:35
up vote 2 down vote accepted

Slowly but surely.. here we go again. I would like to solve these Kernel Panic errors which occur on both Samsung Series 7 and Series 9 laptops! At least on my machine :-) In this Kernel bug report 47121 someone reported that it maybe helps to set the "OS Mode Selection" in the BIOS to "UEFI OS", instead to "UEFI and CSM OS". The packages and libraries that are loaded seem to be different. I needed to switch to "UEFI and CSM OS" to install Ubuntu in the first place. Now I have to switch it off again. But maybe it helps.. After I switched it back to "UEFI OS" it booted ten times without errors. If the Kernel Panic does not occur again, then this seems to be the anwser, and I will mark the question as answered. Hopefully..

share|improve this answer

modify /etc/modprobe.d/blacklist.conf with "blacklist samsung-laptop". Reboot. Problem solved; this will be fixed via a kernel patch (hopefully) soon.

share|improve this answer
I still see machine checks with modern kernels (e.g. 4.0). Setting this in the blacklist has no effect on frequency of lock-ups. – Bryce Apr 26 '15 at 12:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.