Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I start gnome-terminal it looks quite pleasant but when I open another tab it's borders turns ugly:

fat-ugly-gnome-terminal-bezel

How can I preserve thin bezel while using multiple tabs?

share|improve this question

5 Answers 5

up vote 17 down vote accepted

After some messing around, I figured it out.

Edit /usr/share/themes/Ambiance/gtk-3.0/apps/gnome-terminal.css and add:

 TerminalWindow .notebook {
   padding: 0;
   border-width: 0;
 }

Bug found on this: https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/694468

share|improve this answer
1  
Hmm, it seems to make the bezel quite small for me in both gnome-terminal and gnome-terminator. Thanks for pointing this out! I find it kind of hilarious that even Mark Shuttleworth can post a bug to launchpad and have it not fixed 2 years later ;) –  Ibrahim Nov 30 '12 at 6:26
1  
Messed around with it some more and finally got it to work! Now to see if I can apply this fix to Terminator as well.... –  Jonah Braun Nov 30 '12 at 6:43
    
@Ibrahim they had GTK2 2 years ago, now is way easier with CSS. –  Dmitriy Budnik Dec 2 '12 at 20:26
    
Heh true, but Mark Shuttleworth replied a year ago asking if that fix could be incorporated into Ubuntu, and it wasn't ;) –  Ibrahim Dec 3 '12 at 10:03

Well its a good practice in general not to modify the original files but override their values according to your preferences.

If you don't already have it, create or open a gtk.css file in this path

~/.config/gtk-3.0/gtk.css

Paste the following code, close all terminals and start one new.

@define-color bg-grey #222;
@define-color active-grey #333;
@define-color border-grey #555;


TerminalWindow .notebook {
  border: 0;
  padding: 0;
  color: #eee;
  background-color: shade(@active-grey, 1);
}

TerminalWindow .notebook tab:active {
  border: 1px solid @border-grey;
  background-color: shade(@active-grey, 1);
}

TerminalWindow .notebook tab {
  background-color: shade(@bg-grey, 1);
}

Now, not only it will remove the borders as you intended but will also "fit" better with the dark background, my eyes "hurt" with the light gray. The result when you have multiple tabs it should look like this, which of course you can customize it by tampering the color variables according to your preferences.

enter image description here

share|improve this answer

Mine based on @topless and @jibreel answers.
Transparent background and a dark theme. Awesome.

@define-color bg-grey #222;
@define-color active #313131;

TerminalWindow .notebook {
    border: 0;
    padding: 0;
    color: #fff;
    background-color: shade(@active, 1);
}

TerminalWindow .notebook tab:active {
    background-color: shade(@active,1);
}

TerminalWindow .notebook tab {
    border-radius: 0px;
    padding: 3px;
    background-color: shade(@bg-grey, 1);
}

enter image description here

share|improve this answer
1  
All of these answers were helpful and taught me how awesome GTK is for having themes based on CSS. This answer, though... this one is the best. Great look. I won't even be tweaking this any further as I planned. –  Carl Zulauf Nov 6 '13 at 21:12

Thanks @topless, also edited it further to look like this, note the border-radius: 0, to avoid white space

@define-color bg-grey #222;
@define-color active #300A24;

TerminalWindow .notebook {
  border: 0;
  padding: 0;
  color: #eee;
  background-color: shade(@active-grey, 1);
}

TerminalWindow .notebook tab:active {
  background-color: shade(@active, 1);
}

TerminalWindow .notebook tab {
  border-radius: 0px;
  background-color: shade(@bg-grey, 1);
}

enter image description here

share|improve this answer

You can either try another theme, configure Ambiance to your likings, or get one of these ( from Ubuntu software center):

  • Terminator
  • xterm
  • Roxterm
  • Tilda
  • Guake
  • ...
share|improve this answer
    
I do know that there are other terminal apps available, they all look ugly to me –  Dmitriy Budnik Dec 1 '12 at 18:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.