Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to install or remove any application from ubuntu software center I get this error: Package Operation Failed.

As suggested in many posts in this forum I did this sudo apt-get -f install:

sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  codeblocks codeblocks-contrib codeblocks-contrib-dbg codeblocks-dbg codeblocks-dev libwxsmithlib-dev libwxsmithlib0-dev
Suggested packages:
  libwxgtk2.8-dev wx-common
The following NEW packages will be installed:
  libwxsmithlib-dev
The following packages will be upgraded:
  codeblocks codeblocks-contrib codeblocks-contrib-dbg codeblocks-dbg codeblocks-dev libwxsmithlib0-dev
6 upgraded, 1 newly installed, 0 to remove and 243 not upgraded.
5 not fully installed or removed.
Need to get 0 B/84.4 MB of archives.
After this operation, 73.2 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 159995 files and directories currently installed.)
Unpacking libwxsmithlib-dev (from .../libwxsmithlib-dev_10.05-2_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libwxsmithlib-dev_10.05-2_i386.deb (--unpack):
 trying to overwrite '/usr/include/wxsmith/contrib/include/wx/propgrid/advprops.h', which is also in package wxsmith-headers 10.05-1
No apport report written because MaxReports is reached already
dpkg-deb: error:   subprocess paste was killed by signal (Broken pipe)
Preparing to replace codeblocks-dev 10.05-1 (using .../codeblocks-dev_10.05-2_i386.deb) ...
Unpacking replacement codeblocks-dev ...
dpkg: error processing /var/cache/apt/archives/codeblocks-dev_10.05-2_i386.deb (--unpack):
 trying to overwrite '/usr/include/codeblocks/scripting/sqplus/SqPlusConst.h', which is also in package codeblocks-headers 10.05-1
No apport report written because MaxReports is reached already
dpkg-deb: error:   subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libwxsmithlib-dev_10.05-2_i386.deb
/var/cache/apt/archives/codeblocks-dev_10.05-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

In GUI under Package operation failed dialogue box I get this:

installArchives() failed: (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 159995 files and directories currently installed.)
Unpacking libwxsmithlib-dev (from .../libwxsmithlib-dev_10.05-2_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libwxsmithlib-dev_10.05-2_i386.deb (--unpack):  
 trying to overwrite '/usr/include/wxsmith/contrib/include/wx/propgrid/advprops.h', which is also in package wxsmith-headers 10.05-1
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to replace codeblocks-dev 10.05-1 (using .../codeblocks-dev_10.05-2_i386.deb) ...
Unpacking replacement codeblocks-dev ...  
dpkg: error processing /var/cache/apt/archives/codeblocks-dev_10.05-2_i386.deb (--unpack):  
 trying to overwrite '/usr/include/codeblocks/scripting/sqplus/SqPlusConst.h', which is also in package codeblocks-headers 10.05-1
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:  
 /var/cache/apt/archives/libwxsmithlib-dev_10.05-2_i386.deb
 /var/cache/apt/archives/codeblocks-dev_10.05-2_i386.deb
Error in function:   
dpkg: dependency problems prevent configuration of codeblocks:
 codeblocks depends on libcodeblocks0 (= 10.05-1); however:
  Version of libcodeblocks0 on system is 10.05-2.
 codeblocks depends on codeblocks-common (= 10.05-1); however:
  Version of codeblocks-common on system is 10.05-2.
dpkg: error processing codeblocks (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of codeblocks-contrib:
 codeblocks-contrib depends on libwxsmithlib0 (= 10.05-1); however:
  Version of libwxsmithlib0 on system is 10.05-2.
 codeblocks-contrib depends on codeblocks (= 10.05-1); however:
  Package codeblocks is not configured yet.
dpkg: error processing codeblocks-contrib (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwxsmithlib0-dev:
 libwxsmithlib0-dev depends on wxsmith-dev (= 10.05-1); however:
  Package wxsmith-dev is not installed.
dpkg: error processing libwxsmithlib0-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of codeblocks-dbg:
 codeblocks-dbg depends on codeblocks (= 10.05-1); however:
  Package codeblocks is not configured yet.
dpkg: error processing codeblocks-dbg (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of codeblocks-contrib-dbg:
 codeblocks-contrib-dbg depends on codeblocks-contrib (= 10.05-1); however:
  Package codeblocks-contrib is not configured yet.
 codeblocks-contrib-dbg depends on codeblocks-dbg (= 10.05-1); however:
  Package codeblocks-dbg is not configured yet.
dpkg: error processing codeblocks-contrib-dbg (--configure):
 dependency problems - leaving unconfigured
share|improve this question

1 Answer 1

up vote 1 down vote accepted

Looks like Code::Blocks is broken on your system, best to remove and reinstall it:

sudo dpkg -P all_codeblocks_pacakges_here

Same goes for libwxsmith.

share|improve this answer
    
I did sudo dpkg -P codeblocks this destroyed me: at least code::blocks used to run with codeblocks in the terminal now; it doesn't run and the problem persists. –  Prakash Gautam Nov 24 '12 at 11:50
    
Did you remove all the codeblocks and libwxsmith packages with dpkg -P? If not, do so and reinstall them afterwards with apt-get. –  Dennis Kaarsemaker Nov 24 '12 at 11:52
2  
I removed all packages with unmet dependencies related to codeblocks shown in the Package Operation Failed dialogue box. Then reinstilled it. You put me out of a great misery. Thank you. –  Prakash Gautam Nov 26 '12 at 17:36
    
You're welcome :) –  Dennis Kaarsemaker Nov 26 '12 at 18:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.