Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed xubuntu and transmission daemon, set the download path to my home/user/TV shows, and get a permission denied when trying to download torrents through transmission.

I tried chmod -r 777 on this folder without success.

please help!

output of ps -ef | grep transmission

chen@htpc:~$ ps -ef | grep transmission
109       1023     1  1 21:46 ?        00:00:35 /usr/bin/transmission-daemon --config-dir /var/lib/transmission-daemon/info

chen@htpc:~$ ps aux | grep transmission
109       1023  3.2  0.4  47684 16620 ?        Ssl  21:46   1:20     /usr/bin/transmission-daemon --config-dir /var/lib/transmission-daemon/info
chen      1852  0.0  0.0   4200   772 pts/0    S+   22:27   0:00 grep --color=auto transmission

enter code here
share|improve this question
Can you add the output of ps -ef | grep transmission to the question. I don't think transmission-daemon has the right to write to home dirs by default. – mikewhatever Nov 23 '12 at 20:09
I added it, how do I add permissions to this user ? – Chen Kinnrot Nov 23 '12 at 20:18
Well, I was after the name of the user it runs under, but it's not shown. Try ps aux | grep transmission instead. – mikewhatever Nov 23 '12 at 20:25
Hm..., it looks like its username it 109 - kind of odd. – mikewhatever Nov 23 '12 at 20:39
This is really bizarre, but it should be running under debian-transmission, not sure why it shows a stupid number. You can verify that with id debian-transmission. – mikewhatever Nov 23 '12 at 20:46
up vote 27 down vote accepted

Assuming the path to the download folder is /home/chen/TV shows, run the following:

  • add chen to the debian-transmission group

    sudo usermod -a -G debian-transmission chen
  • change the folder ownership

    sudo chgrp debian-transmission /home/chen/TV\ shows
  • grant write access to the group

    sudo chmod 770 /home/chen/TV\ shows
  • Stop the deamon with

    sudo service transmission-daemon stop
  • The last thing to do is change the file creation mask, so that the downloaded files would be writeable by chen.

    sudo nano /etc/transmission-daemon/settings.json

    … and change "umask": 18 to "umask": 2. Hit Ctrl+O to save and Ctrl+X to exit.

Start the daemon with

sudo service transmission-daemon start
share|improve this answer
In case anyone tries to cd into their directory right after doing this and receive a permission denied, logout and login again. My SSH session did not have the right permissions to access the folder after folder ownership was given to debian-tranmission group (since my user wasn't added to that group until next logon) – matrixanomaly Aug 11 '15 at 6:37
This works up until I need to create a new folder (e.g. the torrent's files are nested). Then I get another permission denied. – GDorn Mar 21 at 19:00
@GDorn That shouldn't be the case. "umask": 2 translates to permissions of 774, or rwxrwxr--, which means fool access for owner and group. – mikewhatever Mar 21 at 19:17

This is a permission issue based on the user ID that is running Transmission. Transmission sets up a default user that you might not expect on first install. The user name is debian-transmission.

I will explain how to change that:

  1. Stop the Transmission daemon sudo service transmission-daemon stop
  2. Open the Transmission config file for editing: sudo nano /etc/init.d/transmission-daemon
  3. Find the line that says USER=debian-transmission and change it to the user that owns the folder in question. If you are not concerned about security issues, you can also use USER=root in this file. (Not advised, but good for troubleshooting).
  4. Alternatively (instead of point number 3), modify the /etc/fstab folder to mount the folder with correct permissions for the user that runs the transmission-daemon.
  5. Start the Transmission daemon sudo service transmission-daemon start
share|improve this answer
That won't work. Here either the user transmission-daemon or root also owns "/var/lib/transmission-daemon/info/settings.json" and if you change the daemon to run as $USER , it will give Couldn't read "/var/lib/transmission-daemon/info/settings.json": Permission denied. It somehow worked in your system , But this is not the proper way to do it. – Khurshid Alam Mar 15 at 10:15

This might be an apparmor profile problem. Transmission runs under the sanitized_helper profile in apparmor.

Look for complaints in /var/log/kern.log. grep transm /var/log/kern.log, particularly just after trying to run transmission and it failing.

share|improve this answer

I had same issue, and that was a mistake I had made when sym-linking the transmission download directory to my home/user/ directory, I changed the ownership of the sym-linked file which by consequence also changed the ownership of the transmission 'download' directory...

I just chowned back to 'debian-transmission' ownership and it worked like a charm (without need to restart service)

#chown debian-transmission:debian-transmission /var/lib/transmission/downloads

(well, you'll have to check according your own linux distribution what is the right owner and eventually also your right path to the downloads directory)

share|improve this answer

This just happened to me. I found this page, was intimidated by all the jargon, so I restarted Transmission, reserved the torrent file to a different location, and saved the torrent data to the same different location (desktop). Worked like a charm...

share|improve this answer

Check if you're using an "incomplete" folder. The error can be misleading in this case and it may be the incomplete folder you do not have write access to.

share|improve this answer

I had similar issue with transmission. I got Permission Error while downloading even with correct folder permission settings on the external USB HDD.

I just mounted the external HDD to the /home/pi/ with the same permissions and it worked fine.

mount /dev/sda /home/pi/USB-HDD-MOUNTED

permissions are drwxrwxrwx (0777) pi:debian-transmission. user name is changed to pi in /etc/init.d/transmisssion-daemon.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.