Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

when I try to update and type:

sudo apt-get update

I get this error

E: Problem executing scripts APT::Update::Post-Invoke-Success 'test -x /usr/bin/apt-show-versions || exit 0 ; apt-show-versions -i'
E: Sub-process returned an error code
share|improve this question
What do you get if you run sudo apt-show-versions -i? Are you sure you need apt-show-versions? – Florian Diesch Nov 23 '12 at 19:19
not a reference at /usr/bin/apt-show-versions line 218 – Mj125 Nov 23 '12 at 19:43
I change my repositories, but it doewsn't help – Mj125 Nov 23 '12 at 19:55
up vote 6 down vote accepted

That sounds like a bug in apt-show-versions. If you don't really need apt-show-versions you may just remove it, for example by running

sudo apt-get purge apt-show-versions

If you don't know if you need it you quite likely don't need it.

If you need the program you could at least remove the file


and file a bug report.

share|improve this answer
works for me on ubuntu 14.04 – realhu Dec 9 '15 at 16:42

I know this thread is old, but because people find it when searching for help I thought I would add another answer. Memory. If you are out of memory you will get this error. You can fix this quickly by adding swap space if you don't already have any.

share|improve this answer

I just got the same error. I am running ubuntu 14.04 server.

I determined it was because I had too many old packages hogging space. I have been running automatic updates for over a year straight. I guess it isn't so automatic!

After running dpkg --configure -a and apt-get clean, I ran apt-get purge apt-show-versions and I am pretty sure that apt-get autoremove got me back in business.

It took a few attempts to finish the job -- autoremove got stuck a few times. Each time, some files would be removed and then it would crap out. It went from 4gb down to 700MB and finally 70MB.

During the process I was informed that my linux image was unstable. It was the latest version so I assume that it was related to the original problem.

After running apt-get update && apt-get upgrade everything seems to be fine

I cleared the clutter out of /boot for good measure.


share|improve this answer

I have to say I'm a beginner of Ubuntu but try to follow this guide:

Updating problems in 12.04

Antonio says that it worked! Let's hope it will work for you too, even though the problem maybe isn't the same!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.