Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install the 32-bit gstreamer plugins on my 64-bit system (Ubuntu 12.10 based). I can install the packages gstreamer0.10-plugins-base:i386 and gstreamer0.10-plugins-good:i386. However, gstreamer0.10-plugins-bad:i386, gstreamer0.10-plugins-bad-multiverse:i386 and gstreamer0.10-plugins-ugly:i386 conflict with 64-bit packages already installed on my system:

$ sudo apt-get install gstreamer0.10-plugins-bad:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gstreamer0.10-plugins-bad:i386 : Depends: libass4:i386 (>= 0.9.7) but it is not going to be installed
                                  Depends: libdca0:i386 but it is not going to be installed
                                  Depends: libdvdnav4:i386 (>= 4.2.0+20120524) but it is not going to be installed
                                  Depends: libdvdread4:i386 but it is not going to be installed
                                  Depends: libslv2-9:i386 (>= 0.6.4-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

...

$ sudo apt-get install gstreamer0.10-plugins-bad-multiverse:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libavcodec53:i386 libavutil51:i386 libfaac0:i386 libfaad2:i386 libgsm1:i386
  libmjpegtools-1.9:i386 libmp3lame0:i386 libquicktime2:i386
  libschroedinger-1.0-0:i386 libswscale2:i386 libva1:i386 libvpx1:i386
  libx264-123:i386 libxvidcore4:i386
The following packages will be REMOVED:
  gstreamer0.10-plugins-bad-multiverse libfaac0 libmjpegtools-1.9
  mint-meta-codecs
The following NEW packages will be installed:
  gstreamer0.10-plugins-bad-multiverse:i386 libavcodec53:i386 libavutil51:i386
  libfaac0:i386 libfaad2:i386 libgsm1:i386 libmjpegtools-1.9:i386
  libmp3lame0:i386 libquicktime2:i386 libschroedinger-1.0-0:i386
  libswscale2:i386 libva1:i386 libvpx1:i386 libx264-123:i386 libxvidcore4:i386
0 upgraded, 15 newly installed, 4 to remove and 5 not upgraded.
Need to get 9,198 kB of archives.
After this operation, 23.3 MB of additional disk space will be used.
Do you want to continue [Y/n]?

...

$ sudo apt-get install gstreamer0.10-plugins-ugly:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gstreamer0.10-plugins-ugly:i386 : Depends: libdvdread4:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This means that I can't play mp3s (among other things) in 32-bit applications that use gstreamer. Is there a way around this?

share|improve this question
    
The closed vote may not be a dupe as stated –  Ringtail Nov 23 '12 at 17:42
    
Have you tried playing MP3s in a 32-bit application? I just ask because 32-bit apps should run fine on a 64-bit system, and if they have dependencies then they should be installed automatically. –  Chris Wilson Dec 2 '12 at 12:56

1 Answer 1

The libraries apt is refusing to install (such as libdvdread4) haven't been multi-arched yet. So, they can't have both amd64 and i386 versions of the same library co-installed.

There's not much you can do, except help us multi-arch more libraries.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.