Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Acer Aspire that I have dual booting XP and Ubuntu.

On the Windows side, the driver allows you to set how close your finger has to be to the edge of the TouchPad before it goes into scroll mode. In Ubuntu I don't have the option (at least in the GUI) to change the scroll area on the pad.

Is there a conf file or other way to change this? I'm constantly getting into the scroll area during normal usage. I would like to leave it on without losing so much pad area to the scroll feature.

share|improve this question
    
please paste xinput list output from terminal. –  ulidtko Jan 18 '11 at 14:59
    
⎡ Virtual core pointer id=2 [master pointer (3)] ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)] ⎜ ↳ SynPS/2 Synaptics TouchPad id=12 [slave pointer (2)] ⎜ ↳ Macintosh mouse button emulation id=13 [slave pointer (2)] ⎣ Virtual core keyboard id=3 [master keyboard (2)] <snip> –  MikeVB Jan 19 '11 at 10:33
add comment

3 Answers 3

up vote 2 down vote accepted

Unfortunately I have never found a reliable GUI for configuring such a thing. You'd have to use command line to alter the settings. It's a very ugly and hairy route.

This isn't what you're asking but here's a script I use on my own Acer Aspire. Perhaps you can use it:

#!/bin/sh

sleep 5
xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Pressure" 32 10
xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Width" 32 8
xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Two-Finger Scrolling" 8 1
xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 8 1 1
xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Edge Scrolling" 0 0 0

If you make a .sh file, mark it as executable and set it to run on startup then you will have disabled edge scrolling and instead have fairly decent two-finger scrolling.

I do not know of any method to change the threshold, unfortunately. I have looked around many times for such settings. Xorg is severely limited in these areas, unfortunately.

share|improve this answer
add comment

Change the Synaptics Edges property, specifically the second value - that's what I did, and it worked.

share|improve this answer
    
e.g. on my Asus N56VZ I had to put xinput --set-prop --type=int 'ETPS/2 Elantech Touchpad' "Synaptics Edges" 136 2884 110 1942 on autostart (the second argument's default value was 3284 and it left far too narrow stripe for scrolling). –  Adam Ryczkowski Jun 8 '13 at 11:34
add comment

Use command synclient. To list current values type synclient -l, to change for example RightEdge type synclient RightEdge=4000.

To make it work on startup copy /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf and add your options into /etc/X11/xorg.conf.d/50-synaptics.conf.

For example, I added the following into the file (but I use touchpad only for scrolling, so it is the opposite of what you need, but you can adapt the values):

Option      "RightEdge" "2000"
Option      "BottomEdge" "2000"

Restart.

Taken from http://ubuntuforums.org/showthread.php?t=886449

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.