Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Numlock turned on on boot-up

i wanted to get the keyboard Numlock on when starting the computer. To accomplish this i went to system settings -> input devices -> keyboard and in the section "Numlock on when kde starts" checked "Turn on".

But that is not lighting up the NumLocK at startup.

what is the right place to accomplish this ?

share|improve this question

marked as duplicate by Marco Ceppi Jun 5 '11 at 20:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Edit /etc/kde4/kdm/Xsetup (if you are still running kde3 you'll need to edit /etc/kde3/kdm/Xsetup instead) and add the following code to it:

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on fi

That code should work if you install numlockx (sudo apt-get install numlockx)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.