Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I'm running Kubuntu 10.04 on an x86 machine, most updates applied. I need to get into single-user mode to install the latest nvidia drivers to support my new dual-display graphics card, but nothing seems to work.

  • If I run sudo telinit 1 it starts the reboot, gets to the point where the splash screen is counting down (cycling through the five dots) and then just hangs.
  • If I press {Shift} during boot-up, I (usually, but not always) get to the Grub menu (v1.9-ish), select the recovery mode option with the latest kernel, and then see the screen with all the options but my keyboard is inoperative: no arrow keys work, for example, so I cannot select the option I want. The only thing that works is {Ctrl-Alt-Delete} to reboot.

I am considering going into /etc/init/rc-sysinit.conf and setting the DEFAULT-RUNLEVEL to S but am hoping there is a nicer way to clean up whatever is going on.

share|improve this question

closed as off-topic by Luis Alvarado Jul 26 '14 at 17:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

Grub: Ctrl-P for up and Ctrl-N for down. –  Rinzwind Nov 23 '12 at 15:10
Thanks; I'll give that a try as soon as I can get the Grub menu back again. I see the "Grub loading." message but then no menu. –  JESii Nov 23 '12 at 15:54
OK; reset GRUB_HIDDEN* options to see the menu, but Ctrl-P and Ctrl-N do not work. –  JESii Nov 23 '12 at 16:01
Tried a new keyboard direct to the computer (without going through KVM and/or USB hub) and still no up/down working. –  JESii Nov 23 '12 at 18:23
Very strange... I found that if I quickly typed a character key twice (such as 'n') that it would take me to the 'network boot' option, so I was finally able to get into single-user mode and install the nvidia drivers. Go figure. –  JESii Nov 25 '12 at 15:49

Browse other questions tagged or ask your own question.