Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to upgrade Banshee from version 2.0 to 2.6 on Ubuntu 10.04 Lucid. When I run sudo apt-get install ppa-purge I get the error message

E: Couldn't find package ppa-purge.

I am following instructions given in

How do I update banshee to 2.4?

Thanks!

Lou

share|improve this question
    
I followed your instructions, and version 2.0 of Banshee was downgraded to version 1.6 instead of being upgraded to 2.6 What do you recommend now? Lou –  Lou Adams Nov 24 '12 at 0:32
    
This is another question - remember to register your account so that you dont have to keep creating new accounts. ppa-purge downgrades your version. That is its purpose. Since what you have posted is not an answer - this has been removed and has been instead converted to a comment. –  fossfreedom Nov 24 '12 at 10:40

1 Answer 1

You are using a command for 11.10+ for 10.04. That might work but more than often does not.

Looking at the packages on ubuntu.com ppa-purge can be found in lucid-backports and not in lucid: http://packages.ubuntu.com/lucid-backports/utils/ppa-purge So you need to add the backports to your sources. Please read the wiki page thoroughly. Enabling Backports Manually can be done by adding the following line to your /etc/apt/sources.list

deb http://archive.ubuntu.com/ubuntu lucid-backports main restricted universe multiverse

After that a (one time)

sudo apt-get update
sudo apt-get upgrade

should update your resource and the apt-get install ppa-purge should work on your system too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.