Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After an sudo apt-get update and sudo apt-get dist-upgrade, the following error appear:

Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: skype-bin:i386 : Breaks: skype (< 4.1.0.20.0-0ubuntu0.12.04.1) but 4.1.0.20-0ubuntu0.11.10.2 is installed E: Unmet dependencies. Try using -f.

then I try sudo apt-get -f install and the following error appear:

Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following extra packages will be installed: skype The following packages will be upgraded: skype 1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 1 not fully installed or removed. Need to get 0 B/15.3 kB of archives. After this operation, 4,096 B disk space will be freed. Do you want to continue [Y/n]? dpkg: dependency problems prevent configuration of skype: skype-bin:i386 (4.1.0.20.0-0ubuntu0.12.04.1) breaks skype (<< 4.1.0.20.0-0ubuntu0.12.04.1) and is installed. Version of skype to be configured is 4.1.0.20-0ubuntu0.11.10.2. dpkg: error processing skype (--configure): dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure. Errors were encountered while processing: skype E: Sub-process /usr/bin/dpkg returned an error code (1)

How can I update my skype and sort out this problem?

I'm on Ubuntu 12.04 64bit and the following is showed in the graphical update manager.

Changes for the versions: Installed version: 4.1.0.20-0ubuntu0.11.10.2 Available version: 4.1.0.20.0-0ubuntu0.12.04.1

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Hi there has been several updates to skype in span of a day, try to do a --purge remove skype and reinstall. you can also install skype-bin if this doesn't work. It will give you latest skype.

share|improve this answer
1  
sudo apt-get --purge remove skype and then sudo apt-get install skype works, Thanks! –  gsc-frank Nov 23 '12 at 14:59
    
I think there were problems with packaging when they updated the repo to the latest version of Skype. When I tried to update yesterday, apt-get told me it wanted to update skype but it needed skype-bin and it wasn't in the repo. Today it worked. –  sierrasdetandil Nov 23 '12 at 15:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.