Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I type in the command

    emulator @Andreud

where 'Andreud' is the name of the AVD I created, it gives the following errors

    PVRDRIInitPVR2D: PVR2D device index (0)Failed to load
    error cannot open shared object file: No such file or directory
    Failed to load
    error cannot open shared object file: No such file or directory

and a blank screen in the emulator window, where I should get android home screen, icons, etc shows up.

As per a comment I tried installing ia32-libs

    aneesh@nb14:~$ sudo apt-get install ia32-libs
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package ia32-libs is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'ia32-libs' has no installation candidate

I want the home screen to appear. Any help is greatly appreciated.

share|improve this question
up vote 3 down vote accepted

On a 64 bit system you need the 32 bit libraries for the Android SDK:

For Ubuntu 13.04 or below:

sudo apt-get install ia32-libs

For Ubuntu 13.10 or above:

sudo apt-get install libgl1-mesa-dev:i386

The ia32-libs are a 32 bit compatibility package for 64 bit systems, thus only available in such. If you already have a 32 bit installation, you have to install libGL separately:

sudo apt-get install libgl1-mesa-dev
share|improve this answer
I have updated my question to include the error. Is there anything else I must do? I have installed open-jdk-6-jdk and downloaded an android sdk. – Host-website-on-iPage Nov 23 '12 at 11:00
I also installed the android sdk of course – Host-website-on-iPage Nov 23 '12 at 11:38
Edited my answer. Didn't think of the possibility of you having a 32bit system. Sorry ;-) – André Stannek Nov 23 '12 at 11:42
I saw that the errors "Failed to load libGL ..." are gone. That's a start! Thank you very much. However I still get the blank screen/screen with just "android" written. Still only some of the dpad buttons enabled. – Host-website-on-iPage Nov 23 '12 at 13:58
Glad I could help. Please mark my answer as solution to your problem. This way other users can see that your problem is solved. – André Stannek Nov 23 '12 at 14:30

Type command

emulator-arm @Andreud

Hope this helps :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.