Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using ubuntu 12.04 with an Atheros wireless card. My internet speed in W7 is great. My internet speed in Ubuntu 12.04 at a university network is great. My internet speed in Ubuntu 12.04 at my home network is really slow.

Some solutions I have tried but didn't work:

  • Disabling IPv6
  • Running the following code:

    sudo ifconfig wlan0 down
    sudo rmmod -f iwlwifi
    sudo modprobe iwlwifi 11n_disable=1
    sudo ifconfig wlan0 up
    

Thanks for the help!

share|improve this question
add comment

1 Answer

sudo -s
echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf

Found this code on here somewhere. It fixed my problem. Might not work immediately though. I had to do a restart.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.