Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Firefox, middle mouse button/wheel has been assigned "Open link in new tab" action for a while now, by default.

Since I ran Software Update tonight, this action doesn't work in Firefox anymore. To be specific, middle mouse click doesn't open links anymore. At the same time, it closes tabs just fine (middle-click a tab == 'Close tab').

I don't know the update details, but I remember that Firefox update was there among other things.

I tried running Firefox with a clean profile and middle button did work there, so something must've changed with existing settings.

share|improve this question
up vote 1 down vote accepted

Go to about:config and disable option middlemouse.contentLoadURL, it should bring back the old middle-click behavior without restarting Firefox. It's a new feature in Firefox 17, that makes you open new tab with URL copied from your clipboard, with middle-click. Needles to say, it interferes with the usual middle-click action, I hope Firefox team will fix that.

share|improve this answer
Opened Firefox and 1) middle click works again, 2) that option is already set to false. Could they fixed it already in one of the updates?.. Doesn't matter to me since I've switched to Chrome now, but thank you anyway! – diversario Dec 17 '12 at 3:23

This isn't an answer, but I've noticed the same thing, and it isn't Ubuntu-specific. I saw it on Win7. It started about the time I updated to Firefox 17. I also have "true" for that flag in about:config.

share|improve this answer

Since Firefox 17 was released 2 days back and Ubuntu provided update to Firefox through its update manager, so it is very possible that some changes had taken place that is why your settings are not working.Try this:
In the adress bar type: about:config
Look for: "browser.tabs.opentabfor.middleclick" and toggle it settings.

share|improve this answer
I tried that already, it is set to "true" and switching/restarting/switching doesn't change anything. – diversario Nov 24 '12 at 11:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.