Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Amarok 2.6.0, on KDE version 4.9.3, on Kubuntu 12.04. I would like to be able to copy my music onto my MP3 player (in this case, my iPhone 3), but to transcode the tracks as I copy them over. However, when I right-click on the selected track, and choose "Copy to Collection" and select my iPhone, the option to transcode to MP3 is greyed out.

What additional packages does Amarok need in order to enable the transcode to MP3 option?

Oh, the "Amarok DIagnostics" output, from the Help menu gives:

Amarok Diagnostics

Amarok Version: 2.6.0
KDE Version: 4.9.3
Qt Version: 4.8.2
Phonon Version: 4.6.0
Phonon Backend: GStreamer (4.6.2)
PulseAudio: Yes

Amarok Scripts:
    Amarok Script Console 1.0 (stopped)
Discogs 1.1b (stopped)
Lyricwiki .2 (stopped)
Free Music Charts 1.6.0 (stopped)
Librivox.org 1.0 (stopped)
Cool Streams 1.0 (stopped)
BBC 1.1 (stopped)

Amarok Plugins:
    AudioCd Collection (enabled)
DAAP Collection (enabled)
MTP Collection (enabled)
MySQLServer Collection (enabled)
MySQLe Collection (enabled)
UPnP Collection (enabled)
Universal Mass Storage Collection (enabled)
iPod, iPad & iPhone Collection (enabled)
Ampache (disabled)
Jamendo (disabled)
Last.fm (enabled)
MP3 Music Store (disabled)
MP3tunes (disabled)
Magnatune Store (disabled)
Podcast Directory (enabled)
gpodder.net (enabled)
Local Files & USB Mass Storage Backend (enabled)
NFS Share Backend (enabled)
SMB (Windows) Share Backend (enabled)
share|improve this question
    
Do you have gstreamer and Kubuntu-restricted-extras installed? –  Seth Nov 23 '12 at 3:23
    
@iSeth--I have the following gstreamer packages installed: - gstreamer0.10-alsa - gstreamer0.10-ffmpeg - gstreamer0.10-fluendo-mp3 - gstreamer0.10-nice - gstreamer0.10-plugins-bad - gstreamer0.10-plugins-base - gstreamer0.10-plugins-good - gstreamer0.10-plugins-ugly - gstreamer0.10-pulseaudio - gstreamer0.10-qapt - gstreamer0.10-x - libgstreamer-plugins-bad0.10-0 - libgstreamer0.10-0 - libqtgstreamer-0.10-0 - phonon-backend-gstreamer If I try to install kubuntu-restricted-extras, a whole heap of packages would be removed... –  Jon Pawley Nov 25 '12 at 23:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.