Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently I installed Ubuntu 10.10 on my dev box, making a dual boot with Windows XP. Before installation, everything worked fine, but now Windows XP cannot connect to the network saying that cable is not connected. I tried connecting it to different devices, and it always fails. Under Ubuntu I observe the same issue, but occasionally, usually it works and sometimes it can't find the network.

Do you people think it's Ubuntu related, or is my network card broken?

share|improve this question
Follow these tips to paste your logs into your question, it'll help us help you:… – Jorge Castro Jan 18 '11 at 5:07
It is caused by loading Ubuntu, as I am having the same problem for exactly the same reason. There is nothing wrong with your network card or cable, it is a problem for Windows to recognise the ethernet connection alone. Having removed Ubuntu and restored a windows system image, the problem remains. Even rebooting and resetting the modem doesn't help. I can connect to the internet without any problem using an Ubuntu boot disc, but not at all with Windows, so it's not a hardware problem. I'm trying to find access to the modem to reset the ethernet connection so it can be recognised, but have ne – user12710 Mar 20 '11 at 14:35
up vote 3 down vote accepted

From your description I can only point to two possible failures:

  • Your network card is failing, as you guessed this is a hardware failure.
  • The cable is broken and you should try another cable.

Installing Ubuntu couldn't really have caused the issue, but sometimes these things coincide. Check your dmesg logs for clues, but I'm sure that you will need to replace the ethernet if it's a desktop and get a usb-ethernet dongle if it's a laptop.

share|improve this answer
I did try exactly that. One cable connecting me to one router, and another cable connecting me to another router. Both fail. What puzzles me is that in Windows they fail always, and in Ubuntu they fail sometimes. – Septagram Jan 18 '11 at 6:07

Are you using DHCP? If not, ensure you are not using an IP address that is already assigned to another box.

share|improve this answer
this can't possibly be the answer because connection detection and ip-addresses are two different layers. From the description, it appears the link layer is failing, not the ip layer. – Martin Owens -doctormo- Jan 18 '11 at 5:45

Problem solved by re-establishing Windows contact with ethernet using an old PC. This is the second time this has happened, but I had assumed it was a hardware problem before on the first PC. As all is now well, I will not be restoring Ubuntu to this PC.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.