Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have my xyz.conf upstart config file in my $HOME/.init directory. When I run "start xyz" I get this error:

start: Rejected send message, 1 matched rules; type="method_call", sender=":1.56"           (uid=1001 pid=11389 comm="start xyz ") interface="com.ubuntu.Upstart0_6.Job" member="Start" error name="(unset)" requested_reply="0" destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init")

Thats what inside of my xyz.conf:

start on startup
stop on shutdown

env HOME=/home/qwerty

setuid qwerty
setgid qwerty

exec $HOME/xyz/xyz

I am using Upstart 1.5 and "qwerty" is non-privileged user. Is there a solution except using su/sudo/start-stop-daemon?

share|improve this question

closed as too localized by Kevin Bowen, Basharat Sialvi, Thomas W., Eric Carvalho, Uri Herrera May 30 '13 at 5:04

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

You must enable user jobs, see duplicate askubuntu.com/questions/219760/… –  Tuminoid Nov 29 '12 at 8:02
This question appears to be abandoned and unanswered. If you solved it, please post an answer explaining how it was solved (answering your own questions is not merely permitted, but encouraged when there is no other answer that does the job). If the question no longer applies you may voluntarily delete/close it. –  Kevin Bowen May 29 '13 at 17:52

Browse other questions tagged or ask your own question.