Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a few computers at home. For each of the computers, I can see the internal home network ip address on any given device by typing in ifconfig in the terminal.

If the device is connected to the home network via ethernet connection or via the built-in wireless connections in laptops, the internal ip address for each of the devices seems to be 192.168.0.X.

However, when I connect one of the devices using an external usb modem wireless adapter, which connects to the home network through wireless, when I check the ip address via ifconfig, for some reason it gets assigned 192.168.42.X instead.

Why are the ethernet and build in wireless connections getting 192.168.0.X, but the external usb wireless adapter gets 192.168.42.X?

More importantly, is it possible to force it to get an internal ip address of 192.168.0.X?

share|improve this question
    
this seems like an issue with your modem / router. Did you check those settings properly? –  Goez Nov 22 '12 at 20:48

1 Answer 1

In terms of forcing internal IP addresses, this is known as setting a static IP.

Here is a good article on setting a static IP in Ubuntu,

It basically comes down to:

  1. Finding your gateway IP - IP of the router
  2. Finding the netmask
  3. Finding DNS server (or use Google's 8.8.8.8 and 8.8.4.4)
  4. Picking a static IP
  5. Add them to the connection editor
    • This should be done on a connection basis not machine basis
  6. Restarting networking service (or your machine)

Good luck!

share|improve this answer
    
Just tried this now and failed miserably, for some reason it stopped me from accessing the internet altogether. I will try again tonight when I have more time. Thanks. –  oshirowanen Nov 23 '12 at 8:52
    
often a problem with incorrect settings. What static IP did you choose? The static IP you choose could not work if it clashes with the range of DHCP assigned IP's –  captain_G Nov 23 '12 at 11:42
    
Still can't get this to work, really confused. By the way, why is my laptops ip address different from my phones ip address when the laptop is connecting to the internet via the phone? Shouldn't the ip address be coming up the same on both devices as it's a single connection? –  oshirowanen Nov 23 '12 at 20:38
    
the internet connection coming into your house is completely separate from the internal static ip you are setting. your router will assign different ips to each connected device unless the device uses its own static up. your router will automatically assign ips with a certain range, you need to assign a static ip outside o fthat range. what make and model is your router? –  captain_G Nov 24 '12 at 12:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.