Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

trying to get a second drive to mount into /media/media folder:

/dev/sda /media/media ext4 auto,exec,rw,user,async 0 0

but it is failing, causing me to skip.

Using 12.04.

Here is the full fstab file:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdb1 during installation
UUID=72e34f04-a84f-41b5-931c-8e1a08b0315e /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdb5 during installation
UUID=d2a7845a-01cc-4a55-93a6-f86b694804de none            swap    sw              0       0
/dev/sda /media/media ext4 auto,exec,rw,user,async 0 0  

Here is my error:

fsck.ext4: Bad magic number in super-block while trying to open /dev/sda
/dev/sda: 
The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device&gt;

mountall: fsck /media/media [708] terminated with status 8
mountall: Unrecoverable fsck error: /media/media
/dev/sdb1: clean, 197231/7331840 files, 1544679/29305088 blocks
Ignoring errors with /media/media at user request
mount: wrong fs type, bad option, bad superblock on /dev/sda,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

mountall: mount /media/media [808] terminated with status 32
mountall: Filesystem could not be mounted: /media/media
Skipping /media/media at user request
share|improve this question
    
it is failing, How? What is the output? –  Lucio Nov 22 '12 at 18:51
    
I have included the output of /var/log/boot.log –  Mild Fuzz Nov 22 '12 at 19:01
    
The second drive would probably be designated as /dev/sda2 or /dev/sdb1, depending on what you mean by "drive". /dev/sda is the first HDD, that, apparently, contains the Ubuntu system partition (/dev/sda1) and the swap partition (/dev/sda5). Mounting /dev/sda obviously won't work. –  mikewhatever Nov 22 '12 at 19:27
    
My operating system is installed on /dev/sdb. It's mounted as sdb1 at / –  Mild Fuzz Nov 22 '12 at 19:32
4  
Since we don't know anything about your setup, why don't you post the output of sudo fdisk -l, and tell exactly what you wish to mount. –  mikewhatever Nov 22 '12 at 19:36

1 Answer 1

up vote 2 down vote accepted

I think the problem may be that you are trying to boot a device rather than a drive. These instructions may help.

Try running sudo blkid. This will give a list of the drives and their unique identifiers (UUID). The output will be something like... (there will probably be more)

/dev/sdb3: LABEL="extras" UUID="94b47b57-1f66-4e1f-8280-4b016c6c055e" TYPE="ext4" 
/dev/sdb5: LABEL="backup" UUID="4b55b1c7-7219-48b4-a82f-b4affb4896df" TYPE="ext4"

find the UUID for the drive/partition you are trying to boot automatically and use this UUID in your /etc/fstab file. Also try mounting with default options. The line would look something like.....

UUID=<UUID> /media/media    <TYPE>    defaults      2 2

Replace <UUID> and <TYPE> with the options that were listed from blkid.

IMPORTANT: make sure /media/media exists

Good luck

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.