Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i'm having problens installing or upgrading skype in ubuntu 12.04 x86-64 after recent skype upgrade.

sudo apt-get install skype

it says skype depends on skype-bin and I'm having held packages. I purged skype abd skype-bin and all it's dependancies but still no go. Why does it happen on LTS which I use in my office??

share|improve this question
1  
try sudo apt-get install -f –  Web-E Nov 22 '12 at 17:47
    
of no use. It runs ok. –  net cat Nov 22 '12 at 18:13
    
after recent apt-get update everything goes fine. skype is installed. The question why does it happen with LTS distro recommended by Canonical to run at critical machines still persists. –  net cat Nov 22 '12 at 18:17
    
damn, now the microphone is not workingALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so –  net cat Nov 22 '12 at 18:21
    
@netcat, I think you should add an Update section in your question body, explaining your current state and actual question. –  saji89 Jan 24 '13 at 9:32

3 Answers 3

This worked for me. (the skype downloaded from the website it self directly gave me errors. http://xchamitha.blogspot.co.uk/2013/07/install-skype-in-ubuntu-1304.html

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. So, you should edit your answer and include those commands mentioned in that blog. –  Alaa Ali Jul 28 '13 at 10:19

Errors like absence of /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so means that Skype needs libasound2-plugins:i386.

So my recipe that helps me is to run the following command:

apt-get install libasound2-plugins:i386
share|improve this answer

I had a similar problem with 12.10. It seems a dependency problem.

I simply installed skype-bin first and then skype and everything worked perfectly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.