Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This may a Firefox question rather than Ubuntu but since the plug-in seem to be integrated with the Ubuntu status bar so I think I should try my luck here.
Just update to Firefox 17 and not sure why now when I go to Facebook a icon show in launcher and a entry for Facebook at the top-right conner under the message icon.
How can I disable this plug-in? It not in the list of my Extensions or Plugins list! Update Here is an screenshot: enter image description here

share|improve this question
    
an image could help us much .:D –  AgentCool Nov 22 '12 at 12:33
    
Tks, I just upload a screenshot. I can not take a screenshot when click on the message icon, not sure why! –  nvcnvn Nov 22 '12 at 12:39

2 Answers 2

up vote 1 down vote accepted

This is unity webapps feature of Unity. Here is a related post on OMGUbuntu

This feature is totally unrelated to the firefox version you are using. You can stop the integration by disabling Unity webapps extension from Firefox addons.

Firefox 17 adds a social integration option. However, this does not integrate with Unity environment the way you have shown.

Related Questions

share|improve this answer
    
I think this may be the correct answer but I can't be sure because I'm not using Unity. –  user25656 Nov 22 '12 at 15:21

You can do so by entering about:config in the address bar of Firefox and hitting enter. You'll get a warning, but just okay that. Then, enter social in the search bar of the page that is now open. You'll then see just a few lines like this (I've inserted spaces to make things non-clickable):

social.activation.whitelist;h t t p s ://ww w.facebook.com  
social.active;true  
social.enabled;true  
social.manifest.facebook;{"origin":"h t t p s ://www.fac ebook.com","name":"Facebook Messenger","workerURL":"h  t t p s://www.facebook.com/desktop/fbdesktop2/socialfox/fbworker.js.php","iconURL":"d a t a :image/x-icon;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8%2F9hAAAAX0lEQVQ4jWP4 %2F%2F8%2FAyUYTFhHzjgDxP9JxGeQDSBVMxgTbUBCxer%2Fr999%2BQ8DJBuArJksA9A10s8AXIB oA0B%2BR%2FY%2FjD%2BEwoBoA1yT5v3PbdmCE8MAshhID%2FUMoDgzUYIBj0Cgi7ar4coAAAAAS UVORK5CYII%3D","sidebarURL":"https://www.facebook.com/desktop/fbdesktop2/?socialfox=true"}  
social.sidebar.open;true  
social.sidebar.unload_timeout_ms;10000  
social.toast-notifications.enabled;true  

What you then need to do is to highlight, one at a time, the lines with social.active;true and social.enabled;true and hit enter each time. Hitting enter will toggle between true and false. You can do so for whichever additional lines you wish.

(Note the long line of code. That one draws the Facebook icon because it's a data URL.)

I must stress that my code above is slightly different than what you may see because I'm using Firefox 17 (beta) and not Firefox 17 (stable) and in my version Facebook is off by default.

After you've done your changes, close the about:config tab (or window) and things should be fine after you restart the browser.

Oh, and while I was writing this answer you provided an image. Now, I'm not using Unity, which has a few "social" activities of its own but still what I've suggested may help!

share|improve this answer
    
nice explanation vasa1 . +1 . –  AgentCool Nov 22 '12 at 12:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.