Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Eclipse 4.2 x64 on Ubuntu 12.10 x64. I need to use the internal web browser but it is disabled by default.

The Use internal web browser radio button in preferences -> General -> web browser is disabled. How can I enable it?

I have installed Eclipse 4.2 x64 in another PC that uses Ubuntu 12.04 x64 and the internal browser works perfectly.

share|improve this question

4 Answers 4

up vote 0 down vote accepted

That checkbox opens up only if you meet the criteria set in their FAQ. Copy/paste from there:

Question: What do I need to run the SWT Browser inside Eclipse on Linux?:

Answer: The browser versions that are supported by each Eclipse release are listed below. Note that Mozilla/XULRunner versions that are not final releases (eg.- betas, alphas, nightlies) are not supported, even if their version technically satisfies a listed version range. Also note that the Mozilla/XULRunner must be compiled for the same architecture as the SWT jar that is being used.

Eclipse 3.0.x: Mozilla 1.4 GTK2 - 1.6 GTK2.
Eclipse 3.1.x: Mozilla 1.4 GTK2 - 1.7.8 GTK2.
Eclipse 3.2.x: Mozilla 1.4 GTK2 - 1.7.x GTK2.
Eclipse 3.3.x: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x.
Eclipse 3.4.x: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.0.x.
Eclipse 3.5.0 and 3.5.1: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.1.x.
Eclipse 3.5.2: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.x and 3.6.x 
(but not 2.x).
Eclipse 3.6.x: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.x and 3.6.x 
(but not 2.x), WebKitGTK+ 1.2.x (see How do I use the WebKit renderer on Linux-GTK?)
Eclipse 3.7.x/4.1.x: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.x and 3.6.x 
(but not 2.x), WebKitGTK+ 1.2.x and newer
Eclipse 3.8.x/4.2.x: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.x, 3.6.x and 10.x 
(but not 2.x nor 4.x - 9.x), WebKitGTK+ 1.2.x and newer

Also note that a Firefox release whose contained Gecko version correlates with the Mozilla versions above can also be used with Eclipse 3.1 and newer (Linux only), provided that it has been compiled with linkable Gecko libraries. It is important to note that Firefox downloads from mozilla.org do not satisfy this criteria, but Firefox installations that are included in major Linux distributions often do in the absence of a XULRunner installation. Attempting to use a Firefox install without linkable Gecko libraries will throw an error with message "No more handles [NS_InitEmbedding...error -2147221164]".

The version of Mozilla or Firefox installed on your system varies with your Linux distribution. The following Linux distributions meet the minimum Mozilla requirements for using the Browser widget.

RedHat Enterprise Linux 3
Suse 9

2 things seem important:

  • Mozilla/XULRunner must be compiled for the same architecture as the SWT jar that is being used.

  • Eclipse 3.8.x/4.2.x: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.x, 3.6.x and 10.x (but not 2.x nor 4.x - 9.x), WebKitGTK+ 1.2.x and newer


If you meet these criteria and it still does not let you change it you might consider taking this to the Eclipse forum or filing a bug (if you are sure it is all as it should be).

share|improve this answer
    
what should be done so Eclipse can use latest Mozilla Firefox instead of Xulrunner on Ubuntu? –  ttoine Jun 13 '13 at 14:35

I've solved the problem by installing libwebkitgtk in Ubuntu 13.10 and Eclipse Kepler.

sudo apt-get install libwebkitgtk-1.0-0
share|improve this answer
1  
For over a year has I been using eclipse under ubuntu and suffering from html markup fragments all over the phpdoc-generated tooltips. Installing this package fixed that. –  Cthulhu Aug 31 at 19:28

Add the following lines at the end of your eclipse.ini:

-Dorg.eclipse.swt.browser.DefaultType=webkit
-Dorg.eclipse.swt.browser.UseWebKitGTK=true

This enables the use webkit instead of xulrunner.

share|improve this answer
    
This worked for me. –  nariknahom May 4 '13 at 19:36

On Ubuntu 13.04 using Eclipse it automagically worked, I was not sure which webkit I was missing, so I installed all that seemed relevant, if someone has pinpointed which it is, please comment,

Regards,

Gabriel Medina

aptitude install libqt4-webkit libqt5webkit5 libqtscript4-webkit libqtwebkit4 libswt-webkit-gtk-3-jni libwebkitgtk-1.0-0 libwebkitgtk-3.0-0
share|improve this answer
    
thank you thank you! –  Michael Wiles Nov 14 '13 at 9:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.