Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am working with r8712u - with a USB driver for RTL8712U/RTL8192SU devices.

I have EUB9603H wifi usb card and Ubuntu 12.04. Wifi sets to wlan0 with driver r8712u. I want to run my wifi-card in Master mode.

I have tried to use hostapd - but this card is not nl80211.

By typing iwconfig wlan0 mode Master

I get error that this card doesn't support AP mode. But the same card works on Windows in Access Point mode.So I have tried to use and installed windows driver on Ubuntu. But error is the same.

Could you help me, please? Just tell me about the way to solve this problem. Is it real to set this wifi-card in AP mode???

share|improve this question
1  
I am not sure whether you have tested the card for mac80211 framework. Most devices failed to go to Master mode using iwconfig. My suggestion is revert back all the changes (like ndiswrapper if you have installed.) and read carefully and try this I am not saying this will resolve the issue, but read the ubuntu doc (link is inside the above question) if it doesn't. –  Web-E Nov 22 '12 at 8:09
    
I have already read and tried... Ubuntu driver r8712u from kernel doesn't works... hostapd starts with error while going... It says that driver r8712u is invalid/unknown... Ndiswrapper is killed) –  timonvlad Nov 22 '12 at 10:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.