Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 12.04, 32-bit, Firefox 17

For some reason I can play YouTube videos fine, but on websites like IGN.com the videos never load. Everything plays fine in Chrome, but the videos used to work in Firefox and for some reason they no longer do. Any help will be much appreciated.

share|improve this question
    
I just tried with 32-bit Firefox 17 but on Ubuntu 12.10 and videos worked on IGN.com. Do you have some ad blocker or NoScript or Ghostery type of extension active? Have you tried with extensions disabled? Sometimes, an update to extensions' blocking lists could cause problems for sites that previously loaded just fine. –  user25656 Nov 22 '12 at 5:48
    
did you install extras? –  user84277 Nov 23 '12 at 20:02
1  
possible duplicate of How do I fix Flash issues? –  Stephen Myall Nov 29 '12 at 14:10
add comment

1 Answer

I have no problems with flash usually, but there was one particular elearning site that just didn't want to display it's content, whatever I tried. Ubuntu 12.10 and Firefox.

I installed agent switcher add-on from https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher/ and switch to "Internet explorer 8" (in the Tools menu) - problem solved, all flash content plays OK. This particular site was asking for IE, Firefox or Chrome browser, and Adobe Flash 10 or higher.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.