Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After upgrading to Ubuntu 12.10, Empathy displays 'network error' when trying to connect to Google Talk. In 12.04 (and earlier versions), Empathy was setup and functioning correctly using Google Talk.

In Online Accounts, I have my Google account authorised with Ubuntu. I have tried removing the account and re-adding/re-authorising, but the result is the same.

I have also tried removing and re-installing Empathy ( and Telepathy.

Is there a solution to this problem? Or a way to diagnose the 'network error' further? Any help would be greatly appreciated.

share|improve this question
up vote 1 down vote accepted

Empathy includes a debugger which can be used to display logging information to help diagnose connection issues.

Launch the debugger using: empathy-debugger, then start empathy and logging information will immediately be visible.

In this case, the logs showed the following:

    gabble/-WARNING: 22/11/12 22:44:08.389273: Invalid numeric port '80"
                                               specified in hostname

This is an error caused by a misconfiguration of the fallback servers in /usr/share/accounts/services/google-im.service. A patch is available in the related launchpad bug.

share|improve this answer

The issue could be because of a corporate firewall interfering with the connection. I got around the issue with the following parameters in the "Advanced" section.

Login ID:
Password: **
[x] Encryption required (TLS/SSL) (checked)
[ ] Ignore SSL certificate errors (unchecked)
Priority: 0
Port: 80
[ ] Use old SSL (unchecked)
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.