Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I think this started happening a couple of months ago when I upgraded from 10.04 to 12.04.

Whenever I reboot, network-manager does not start. I have to manually run sudo start network-manager, and then everything works fine.

Things I have already tried (rebooting after each attempted fix):

  • Verified that all of the /etc/rc*.d/*network-manager links exist the way they should.
  • Since network-manager's upstart config file mentions local-filesystems, and my fstab had a reference to a USB HDD that is not connected, I commented that line out of the fstab.
  • sudo dpkg-reconfigure network-manager and then sudo apt-get install --reinstall network-manager
  • Looked in syslog for hints, didn't see anything that jumped out.

I don't think I've modified /etc/init/network-manager.conf, but here it is for reference:

# network-manager - network connection manager
# The Network Manager daemon manages the system's network connections,
# automatically switching between the best available.

description "network connection manager"

start on (local-filesystems
      and started dbus
      and static-network-up)
stop on stopping dbus

expect fork

    # set $LANG so that messages appearing on the GUI will be translated. See LP: 875017
    if [ -r /etc/default/locale ]; then
        . /etc/default/locale

    exec NetworkManager
end script
share|improve this question

5 Answers 5

The 'start on' section lets you know which events need to be emitted before upstart will start network-manager.

In this case it's:

  • local-filesystems
  • dbus
  • static-network-up

Odds are the first two have already been emitted if you have booted to a desktop.

static-network-up is emitted by the /etc/network/if-up.d/upstart script, crucially, the event will not be emitted unless every interface configured as 'auto' in /etc/network/interfaces is up.

In my case I had a left over entry for eth0 in /etc/network/interfaces which was configured to use DHCP, but since there was no ethernet plugged into eth0 DHCP could never succeed.

You can tell upstart to emit events and can use this to check if it is the static-network-up event that's missing.

  • Reboot your computer and don't start network-manager
  • man initctl (you need to run the emit command with sudo so it's no harm to run man initctl to verify commands posted on the internet first)
  • sudo initctl emit static-network-up (you might need to Ctrl+C this after a while)
  • initctl status network-manager (to check if it started)

If this solves your problem check /etc/network/interfaces, comment out everything other than:

auto lo
iface lo inet loopback

Then reboot and hopefully network-manager will start as expected.

share|improve this answer
You're dead right, this is stupid idiotic behaviour from NetworkManager deciding not to start up because something other than lo is in that file, even if it leaves WIFI completely unconfigured! – Forbesmyester Jun 13 at 9:06

Had the same problem but none of the proposed solutions (including some from other forums) helped.

Anyway, after reading Gordon's reply, I simply deleted the and static-network-up line from /etc/init/network-manager.conf . It worked.

share|improve this answer
I guess the problem here is that static-network-up should be fired, but isn't. Do you see a bootup-message "waiting for network configuration"? – Andy Nov 21 '14 at 17:32
@Andy, If he's on wireless, he has no static interface. If he has auth eth0 in his interfaces, it'll wait for several minutes, fail, and never fire the event. – Cerin Jul 25 at 22:01
I guess you mean auto eth0? While waiting for several minutes it will say "waiting for network configuration", that's why I asked. – Andy Jul 27 at 14:04

I had the same problem after switching my thinkpad while reusing the old disk. It still remembered the old MAC addresses. I had to remove them manually in /etc/udev/rules.d/70-persistent-net.rules which fixed the problem for me.

share|improve this answer

Same here on 12.04 - I did:

sudo -s
mv /etc/udev/rules.d/70-persistent-net.rules ~/
touch /etc/udev/rules.d/70-persistent-net.rules


You could also manually edit that file and correct the mac addresses...

share|improve this answer

On my Arch Linux, I needed to run following command and now NetworkManager starts up automatically:

systemctl enable NetworkManager

This enables the NetworkManager to be run at startup. This is what I understand.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.