Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I set up a basic media server to stream to my 360 using uShare. Here are the instructions I used: http://linuxexpresso.wordpress.com/2011/01/02/howto-ubuntu-upnp-server-to-xbox-360/. I can stream avi files fine but I cannot stream mp4s. When I go to videos on the xbox, I can see all of the videos and folders but when I click play for an mp4 nothing happens.

On my ubuntu desktop I can click on the mp4 file and it plays fine. And if I take that file, stick it on a thumb drive and plug it directly into the xbox the mp4 will play off the thumb drive. I'm lost for why it won't work through ushare. Any ideas?

share|improve this question

1 Answer 1

By default, ushare only streams audio mp4 files. I found a fix for this by editing some source code. If you open up the mime.c file and move the mp4 mime type into the video section and change the respective variables, then you can compile and install it to work great.

If you don't feel comfortable doing this, I have written a little script that does it all for you and sets your ushare.conf setting for you in the process! The only problem that I can't figure out is that for some reason, even though the xbox configuration is correct in the file, it still doesn't work unless you send the -x argument into the command line. I suggest removing your previous installation before running my script though, because I don't know what exactly happens if you don't.

You can download it here: https://rapidshare.com/files/2379920576/install%20ushare.zip

Just unpack and run the shell script.

EDIT: This script does not work on Ubuntu 12.10. I just tried it on my new machine and it failed. =[

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.