Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 2 Ubuntus installed: 12.04 and 6.10 After I installed the second one - 6.10, the first one (12.04) became invisible in grub. Then I booted from the 12.04 live cd and followed this http://www.howopensource.com/2012/05/reinstall-recover-grub-from-ubuntu-12-04-live-cd-usb/ article to restore the complete grub using "boot-repair" utility.

Both versions kernels appeared in the list, 12.04 booted fine, but 6.10 became unbootable! Simply when I chose any of them, the system restarts immediately.

Here is an example of grub entry for this:

    Ubuntu, kernel 2.6.17-12-generic (on /dev/sda2)
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos2)'
    search --no-floppy --fs-uuid --set=root f13c4d37-cf48-4e03-91b2-4f4da43a7d73
    linux /boot/vmlinuz-2.6.17-12-generic root=/dev/hda2 ro quiet splash
    initrd /boot/initrd.img-2.6.17-12-generic

When I change root=/dev/hda2 to root=/dev/sda2 it stops from restarting, but it shows nothing but a command prompt and stops. I have also tried removing "ro quiet splash" to see any errors with no luck.

I believe this has something to do with sda/hda thing in different Ubuntu versions, but have not had a luck after hours of searching to determine the solution!

Here is the output of "boot info script": http://pastebin.com/raw.php?i=pVMdHkax

(Couldn't figure out how to correctly attach it here).

Thanks for looking.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

I have found a satisfactory solution for the problem! Credits go to "Super Grub2 Disk" open-source software!!

It is a bootable USB (or any device) disk which has an option in particular: "Detect any GRUB legacy menu configuration file (menu.lst)"

It took me a little while to figure out how to tune in my system and adjust SGD's settings in order to finally successfully boot the Ubuntu 6.10 Edgy !

Later, I have figured out which exactly minimum parameters are required for grub2 to make the successful boot (see the original in my question above):

    set root='(hd0,msdos2)'
    legacy_kernel /boot/vmlinuz-2.6.17-12-generic /boot/vmlinuz-2.6.17-12-generic root=/dev/hda2
    legacy_initrd /boot/initrd.img-2.6.17-12-generic

Note, '/boot/vmlinuz-2.6.17-12-generic' is written twice intentionally, I have checked, having it written only once, it would finish booting process before loading the image (after having loading the kernel).

I have then tried to use the firstly used tool "Boot Repair" and it's "Grub Legacy" Grub option, but it did not made the system multi-boot aware.

I have also tried using "Super Grub2 Disk" to somehow automate the menu repair process, and, again, could not made it being multi-boot aware.

The only ultimate solution I see so far is either manually editing /boot/grub/grub.cfg each time grub is updated, or edit "os-probe" script, so that when it would detect "/dev/hda*" partition, it would automatically use "legacy_" commands.

As the result, I've been able to install the proprietary driver and notice the significant performance increase! For example, TuxRacer became having no lags even on highest resolutions (on highest - only slight overall speed decrease), while when was using Ubuntu 12.04 with it's native drivers, there were lags even on lowest resolutions when you are on a very open space. Another 3d-game I have tried is java browser based SpiralKnights. It became working almost totally stable with no lags on glitches, while on 12.04 there were glitches, lags all the way long. Not even mentioned in details, that I've been able to run the latest FireFox (with even no installation/compilation needed, just download & run), flash 10 version and latest java which made it a totally modern Internet system and already proven that the efforts were worth of trying. I would be further trying to install and use Blender and try to render some great animations.

Similar threads on ubuntuforums with no solutions:

September 7th, 2011 Dell D600 Downgrade to Xorg 7/Dapper no flash ubuntuforums.org/showthread.php?t=1840476

July 29th, 2010 installing Ati radeon 9200 drivers ubuntuforums.org/showthread.php?t=1541719

November 22nd, 2009 Please help me downgrade Xorg ubuntuforums.org/showthread.php?t=1334694

share|improve this answer
add comment

6.10 is 6 years out of date and no longer supported by anyone.

share|improve this answer
    
It has fglrx drivers for my card. I've seen people do downgrades here and there for the sake of proprietary drivers, manually compile the needed software and feel great! The performance in 3D using those drivers is 10 times (!) faster than using the ones shipped in 12.04 Also, I think it's a common problem which started to appear after Ubuntu started to name primary drives like /dev/sda* instead of /dev/hda* I believe there should be a very known solution for this. –  user109764 Nov 21 '12 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.