Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the annoying problem with 12.10 that it lists the extended partition containing my SWAP in nautilus (labeled "Ubuntu 12.10 i386"), so I want to open up disks to check off the 'Show in User Interface' option, only it's grey'd out. Is there a way to open Disks as sudo so i can check off that option?

share|improve this question
    
This shouldn't be necessary: Disks uses PolicyKit everywhere it needs to gain escalated permissions, so as long as PolicyKit is working the only reason that will be greyed out is if something else is wrong. (Maybe there's some oddness with the partition type and Disks is communicating poorly). Just to be sure, I need you to confirm something: is the "Automatic Mount Options" switch set to On or Off? –  Dylan McCall Nov 21 '12 at 18:11
    
Interesting... The Switch is to 'On' and everything is grey'd out –  seanthewebber Nov 21 '12 at 19:51

1 Answer 1

You do not need to run Disks as root to do this. To set your own mount options for a volume, you need to turn off Automatic Mount Options. This is done with the switch at the top of the Mount Options dialog. Just toggle that switch so it says "Off" and you will be able to change the mount options as you see fit. When you click OK, you will need to enter your password for the changes to be applied.

Changing mount options for a volume

With "Automatic Mount Options", volumes are mounted as they appear. When you turn that off, Disks adds an entry to /etc/fstab so the system always knows to mount that disk at startup, and in a particular way. I'm guessing this partition contains a swap file or something of the sort, so you may want to change the Mount Point field or reconfigure your swap file, since the mount point will be different from when it was automatic.

share|improve this answer
    
Noted. I thought that switch was "Do you want to mount at all?" That makes sense. Could I just mimic how it was on automatic and then deselect 'Show in User Interface' to solve the problem? –  seanthewebber Nov 21 '12 at 23:45
    
To answer my question.. that didn't work. I turned off the switch and simply de-selected 'Show in User Interface' and restarted.. it gave me an error mounting my SWAP so I had to switch it back to 'On' to get SWAP working again.. what should I do here? –  seanthewebber Nov 22 '12 at 0:08
    
I thought that might happen. The stuff at the bottom of my answer should cover that. I don't really know how your swap is set up (all I know it isn't an ordinary swap partition), but I assume you set it up yourself at one point. You'll just need to change the configuration for that swap because its partition is being mounted somewhere else. When it was automatically mounted it appeared under /media/YourName/DeviceName, but now it's under /mnt/DeviceName. It's probably better to reconfigure the swap file stuff, because Nautilus actually makes some funny assumptions about files in /media. –  Dylan McCall Nov 22 '12 at 5:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.