Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I could swear I've always been able to do Alt+Print Screen to get 'just that window' but right now I am getting my entire desktop.

Any idea why this would be or what I can do to get my ability to do small window screen shots?

I've tried a lot of combination with the Ctrl, Alt, Shift and Print Screen keys, but no luck, nothing happens in response. One option: Shift+Ctrl+Print Screen lets me do a selection using a cross hair to size out the screen capture but I don't know where this gets saved. I'm not being given the choice and it's not in Desktop or Pictures.

I use an external keyboard, but I've tried using the laptop's own keyboard and no difference.

I am running Ubuntu 12.04 and the laptop is a Samsung Ultrabook 900

Update: I rebooted and it "fixed" it - for now. However this is not the first time I've seen this so I'm still curious as to why it happens, what I can do to fix w/o reboot and if other share the same problem.

share|improve this question
    
what currently happens when you hit those key-combos? –  ImaginaryRobots Nov 21 '12 at 16:06
    
You can try gnome-screenshot -w -d 4. Will take snapshot of window. –  VedVals Nov 21 '12 at 16:06
    
I tried that at the command line and it locked up my machine and I had to reboot. –  Michael Durrant Nov 21 '12 at 16:10
2  
Have you tried Shift+Prt sc? –  Seth Nov 21 '12 at 16:33
    
@Seth, I don't know about your machine, but on mine Shift+PrtSc does the area-select screenshot, just like Shift+Ctrl+PrtSc. –  Waldir Leoncio Dec 1 '13 at 16:15

5 Answers 5

I don't have a fix for this issue, but I could suggest another option: use Shutter Install shutter. It's a pretty advanced screenshot application that lets you do a lot more than just take screenshots - including choosing where to save them.

enter image description here

share|improve this answer

I'm not sure if Ubuntu 12 has a similar settings tools. Pull up System Settings and look at your Keyboard settings. Shortcuts contain many keys that your system may be expect you to use. Make sure you don't have a conflict with another keyboard shortcut and check that your screenshot shortcut is what you are expecting to use. I've disabled the general ALT key for dashboard that might interfere.

This is what it looks like in Ubuntu 13: enter image description here

share|improve this answer
up vote 1 down vote accepted

My 'answer' to this, at least for now was to look for the app itself. So I went to dash home (top left icon with circle) and looked for the 'Screenshot' app then when I saw it I dragged it to my unity icons on the left and now it's simply available as an app and I get the options of capturing just the window, etc. when I use it.

enter image description here

share|improve this answer
    
Just a note: You can also press Shift+PrtSc to be able to select a specific part of the screen. Simply press it, then drag a rectangle over the area you want to screenshot. –  Ian Santopietro Oct 14 '13 at 19:15

The reason this happens is that on many (most?) keyboards the PrtScn key is also the SysRq key, and Alt+SysRq is the "Magic SysRq Key" (see this answer: http://askubuntu.com/a/5168/50450). You can either disable the Magic SysRq key, or change the screenshot window shortcut to something else.

share|improve this answer

ALT + Fn + Prnt Scrn worked for me.

share|improve this answer
1  
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  Elder Geek Jul 7 at 15:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.