Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Windows server that runs postgresql 9.2. I want to hit it using pgAdmin III from my Ubuntu 12.10 workstation box.

I installed pgAdmin III from synaptic and also tried direct download from postgreSQL site using software installer. Regardless, I can get only get pgAdmin III for postgresql 9.1. When I run pgAdmin III and point to my server I get an error message telling me that the database is 9.2 and my pgAdmin III is for 9.1, isn't compatible with 9.2.

I can access the server itself fine OK from the Ubuntu box - I have Python programs that hit the database with no problems - but I need pgAdmin III for 9.2 running under Ubuntu 12.10.

Is it available? Where do I get it?

share|improve this question

3 Answers 3

up vote 4 down vote accepted

As of 2014, this website describes the way to do it for Ubuntu and Debian: https://wiki.postgresql.org/wiki/Apt

Copy paste (2014-06-06) in case website goes offline, whatever happens:

PostgreSQL packages for Debian and Ubuntu

The PostgreSQL Global Development Group (PGDG) maintains an APT repository of PostgreSQL packages for Debian and Ubuntu located at http://apt.postgresql.org/pub/repos/apt/. We aim at building PostgreSQL server packages as well as extensions and modules packages on several Debian/Ubuntu releases for all PostgreSQL versions supported. Currently, we support Debian 6.0 (squeeze), 7.0 (wheezy), and unstable (sid) 64/32 bit (amd64/i386) Ubuntu 10.04 (lucid), 12.04 (precise), 13.10 (saucy), 14.04 (trusty) 64/32 bit (amd64/i386) PostgreSQL 8.4, 9.0, 9.1, 9.2, 9.3, 9.4 beta Server extensions such as Slony-I, various PL languages, and datatypes Applications like pgadmin3, pgbouncer, and pgpool-II Packages for older PostgreSQL versions and older Debian/Ubuntu distributions will continue to stay in the repository; updates for those will be provided on an ad-hoc basis.

Quickstart

Create /etc/apt/sources.list.d/pgdg.list. The distributions are called codename-pgdg. In the example, replace wheezy with the actual distribution you are using:

deb http://apt.postgresql.org/pub/repos/apt/ wheezy-pgdg main

(You may determine the codename of your distribution by running lsb_release -c.) Import the repository key from https://www.postgresql.org/media/keys/ACCC4CF8.asc, update the package lists, and start installing packages:

wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add - sudo apt-get update sudo apt-get upgrade sudo apt-get install postgresql-9.3 pgadmin3

Alternately, this shell script will do the above steps for you. 9.4 beta only: See FAQ on beta releases Have a look at the FAQ. Note: This repository provides "postgresql", "postgresql-contrib", and "postgresql-client" meta-packages that depend on the latest postgresql-x.y, ... packages, similar to the ones present in Debian and Ubuntu. Once a new PostgreSQL version is released, these meta-packages will be updated to depend on the new version. If you rather want to stay with a particular PostgreSQL version, you should install specific packages like "postgresql-9.3" instead of "postgresql". '

share|improve this answer

It is in the repositories.

sudo apt-get install pgadmin3

or search the software center.

software-center

If that is the wrong version, you could use the PPA:

If that does not work you can use the source and compile it yourself from source.

share|improve this answer
    
Thank you - I will try this. –  Vector Nov 23 '12 at 8:05
    
This worked and is more to the point! –  unmircea Jun 14 at 17:35

Version 16 of pgadmin3 ( http://www.pgadmin.org/visualtour16.php ) is required for Postgres 9.2 and it is not in the repo or that PPA for Ubunutu 12.10.

It looks like you have to build it or upgrade.

I've built it for 12.10: https://copy.com/anB4E19CxdLW - perhaps that binary will work for you if you are on 12.10.

If not and you need to build it yourself, make sure you install

sudo apt-get install postgresql-server-dev-9.2
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.