Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Question: What package contains the subprogram responsible for the KMenu option "sleep"?

Background: I've been running KUbuntu 10.04.1 and I am completely updated. Recently (within the past month), the "sleep" menu item has stopped working. It just sits there waiting like I clicked nothing. I've check all of the logs in /var/log and nothing is added when I click sleep.

I'm guessing that something I updated has bollux'ed things up, but I don't know which package contains the component that I need to roll back. In the meantime, I've installed uswsusp, but s2ram & s2both don't ask my password when the laptop resumes -- which really bothers me. So now that I've got a little time to track this down, I had to post -- any ideas??

Update: I've messed around with the versions of acpi for quite some time. It appears to be working. If I run sudo /etc/acpi/sleep.sh it works and the computer suspends. As above, it does not lock the screen first, but at least the damn thing suspends. Oddly, sudo /etc/acpi/sleepbtn.sh does not work.

share|improve this question
    
Let me be uber specific. I rolled acpi-support back to version 0.136 which shipped with Lucid and it still doesn't work. The command sudo acpi_fakekey 142 does nothing -- I don't see anything in the logs. I also don't have /var/log/acpi.log? –  M. Tibbits Feb 3 '11 at 2:26
    
Further, I'm now running the latest Lucid kernel 2.6.32-28-generic and this is Lucid 10.04.2 LTS. I've also checked apparmor -- just in case it was blocking acpi. No luck. I've also added 'acpi=force' as a kernel parameter in /etc/default/grub ala GRUB_CMDLINE_LINUX="acpi=force" and this doesn't help either. Thoughts? –  M. Tibbits Feb 3 '11 at 2:58
add comment

1 Answer

up vote 0 down vote accepted

I do not know yet how to solve this problem; however, to manually suspend and lock the screen in KUbuntu (and perhaps Ubuntu?) I've aliased a command which I'm sure others can use -- so I want to post it here. I'm also going to reclaim the bounty and keep offering it until someone answers...

If you do:

sudo qdbus org.freedesktop.ScreenSaver /ScreenSaver Lock; sudo pm-suspend

This will first lock the screen and then issue a suspend command. Although sudo isn't needed for the first command, you'll want to enter the password before the screen locks because you'll have to unlock it to gain sudo ability to suspend if you don't.

share|improve this answer
    
Just wanted to pass along that updating to 11.04, everything works now. Initially I used the update manager & dist-upgraded from 10.04 to 10.10 to 11.04, but a few third party packages stopped working. The suspend was also not working at this point. So I did a fresh install and now suspend is working again. –  M. Tibbits May 2 '11 at 17:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.