Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Windows7 guest running in a VirtualBox hosted by Precise (Ubuntu 12.04 LTS). In the settings of the virtual machine I have activated the 'Remote Display' (Enable Server) with default settings (server port, authentication method). The network of the guest is attached to NAT.

  1. I try to use Remmina to connect from the host to the guest. I tried 127.0.0.1, 127.0.0.2, the internal IP of Win7 (10. ...). Did not work so far. Do I have to active something and what on Win7 (home premium)?
  2. I would like to connect to the Win7 remote desktop from the local network. Can I stay in NAT mode (preferred due to our network policy), or do I have to go for 'bridged'?

Thanks!

share|improve this question
    
I know that there are a couple similarly sounding questions (and answers) around. However, I could not find one to solve my question. –  Andre Nov 21 '12 at 4:03
add comment

1 Answer 1

here 127.0.0.1 will not connect your virtual guest system. Apply Bridge and find guest's Ip address ( windows 7 ip address) by ipconfig or network settings. Then after try that ip to connect using Remmina.It will 100% work.

share|improve this answer
    
Which version of Win7 are you using? I've read that Remote Desktop is only possible to Professional and Business. Or is the remote desktop provided by VirtualBox independent from what Windows is providing? –  Andre Nov 22 '12 at 1:35
    
You can access Win 7 home premium (all adddtions ) Guest from Ubuntu host. Windows 7 Home premium is not able to access take remote of other host. –  K.K Patel Nov 22 '12 at 3:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.