Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason Gnome 3 wont work in my virtualbox. Both gnome classic and gnome look exactly identical.

The version of my virtualbox is: 4.1.2_ Ubuntu r38459 The 3D acceleration is on in the virtualbox and the Guest Additions is installed in the virtualbox from the software center.

Obviously, the graphic card driver is installed on the main Ubuntu system I am using with my laptop. (although the post-release updates can't be installed for whatever reason)

Gnome shell is installed from the software center in the virtualbox.

Now the issue is that the gnome and gnome classic look like just the same.

Here is an image of what gnome looks like (so does gnome classic too....so I am only posting one image):

enter image description here

What causes this issue?

By the way....I am using Ubuntu 11.10 with gnome fallback session.

NOTE: I have been asked to use the "~$ gnome-shell --replace" command. It basically made the fallback mode into the desired Gnome 3 desktop environment till the next restart, but that's it.

I got this message in the terminal though:

"~$ gnome-shell --replace Window manager warning: Log level 16: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject Window manager warning: Log level 16: Error registering polkit authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject (polkit-error-quark 0)

(gnome-shell:1860): folks-WARNING **: Failed to find primary PersonaStore with type ID 'eds' and ID 'system'. Individuals will not be linked properly and creating new links between Personas will not work. The configured primary PersonaStore's backend may not be installed. If you are unsure, check with your distribution."

UPDATE: this is the image of the additional drivers. As you can see one cant be installed and this is why it's not active. enter image description here

share|improve this question
    
I've updated my answer below with a workaround. Not ideal but a solid way to get around installing the graphics drivers within the virtualbox as well. –  captain_G Nov 22 '12 at 0:49
add comment

1 Answer

up vote 1 down vote accepted

This sounds like a graphical error. Running gnome-shell on a machine (in this case virtualbox) that doesnt meet the requirements will fall back on the classic/fallback session.

Try:

  • open a terminal ( Ctrl+Alt+T )
  • replacing the current session with the shell ( gnome-shell --replace )

This will try replace fallback session with the shell, if it fails at least you will be able to see why because the errors will be output in the terminal.

Updating the question with any errors will help us to help you.

UPDATE: Workaround...

I believe that gnome-shell is failing an accelerated hardware check which takes place when the session is loaded. A workaround would be to load the gnome-shell when you log into the gnome-classic session.

You can do this by creating a file called gnome-shell.desktop, save it to ~/.config/autostart/ Inside it put the following:

[Desktop Entry]
Type=Application
Exec=gnome-shell --replace
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[en]=Gnome Shell Startup
Name=Gnome Shell Startup
Comment[en]=
Comment=
OnlyShowIn=GNOME
AutostartCondition=GNOME3 if-session gnome-classic

There is a difference between gnome-classic and gnome-fallback (classic loads with some effects), if you don't have classic installed change gnome-classic on the last line to gnome-fallback

you will know if its installed if you have 2 Gnome Classic options in your session menu - one will have "(no effects)" written next to it

share|improve this answer
    
There is a little bit of a problem Captain: there is no .config/autostart in the virtualbox. I have found that folder on the main OS, but nothing in the virtualbox. I have obviously pressed CTRL+H. So that is not the issue. –  Elysium Nov 22 '12 at 21:45
    
I'm guessing this is probably because no applications are set to start at startup yet. Try creating the directory yourself aswell. –  captain_G Nov 22 '12 at 22:08
    
I have tried that too. I am giving up on Gnome 3. For some reason it just wont work. Thanks anyway. –  Elysium Nov 22 '12 at 22:30
    
We could have one last shot! open a terminal, type gnome-session-properties, click "Add", Name: Gnome Shell, Command: gnome-shell --replace, Comment: last shot at starting gnome shell in virtualbox! –  captain_G Nov 22 '12 at 22:42
    
This helped, but the animations and the way it behaves in the virtualbox is pretty weird. I might try it on my laptop (if it works better there), but can you do me a big favour and tell me what is happening? Why do I neeed the --replace in the first place? –  Elysium Nov 22 '12 at 22:56
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.