Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

To start, I have two computers I use Ubuntu One on right now. One is a laptop with Ubuntu 12.04 32bit and the other is a desktop with Windows 7 64bit.
I have many files in my Ubuntu One folder and they all seem to sync fine except for one. I have a calc document I edit daily on my laptop. But when I look at it on my desktop it has not been updated in a couple days, and if I save it I get a conflict file on my laptop, but not the desktop. I have tried disconnecting and reconnecting on both (which takes a long time for some reason) and it says file sync is up to date on both.
Any other file if I edit, delete, add. They all sync fine so far, except for this one. What could be the problem?

This is probably related, a couple days ago the same file ended up in the recycling bin on the ubuntu laptop. I did NOT delete it on either computer. I was not happy to find out Ubuntu One does this... Come to think of it, I think that is about when all the sync problems started.

share|improve this question
    
When a file is changed in Windows (for example) and synced by Ubuntu One in Ubuntu, the old version of the file goes to the recycling bin in the Ubuntu laptop. If you have restored the file from Recycling Bin, that would undo the sync. –  user68186 Nov 20 '12 at 19:10
    
I never changed the file in windows (the desktop). In fact the file in windows was the old version and it was Not sent to the recycling bin! The newer file (on the laptop) was the one that was sent to the recycling bin. Sent me into a panic untill I found it in the recycling bin. The older file in windows is the one that is still not syncing now, in other words, the file is not being deleted and then replaced with the new on from the laptop as it is supposed to be. –  user89756 Nov 20 '12 at 19:24
    
Sorry, no idea whats going on then. –  user68186 Nov 20 '12 at 21:10
    
Well, I got it to work. Looks like a problem with the U1 windows client. It is the latest version 3.0.2b I moved the good file to a safe place on my laptop, then I checked to make sure it replicated the removal of the file, and it did. The file was gone on both computers. I then copied the good file back to U1 on the laptop. But it would not replicate it to my windows computer. I reconnected, no change. I completely exited U1 on the windows computer then restarted it and it then synced properly. I shouldn't have to restart U1 for it to work... –  user89756 Nov 21 '12 at 23:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.