Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot get Virtualbox to install properly on my 12.04. I first went with a manual install for the .deb from the old builds section of the Virtualbox page. That .deb opened up the Software Center and installed. Then I got the error coming up of

VT-x/AMD-V hardware acceleration is not available on your system. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot.

which I can only assume was due to my Ubuntu version being 32-bit (System Details -> Overview -> OC type: 32-bit, right?) So I followed these instructions to remove the .deb manually, restarted my laptop, and then FOUND the actual Virtualbox install in the Software Center and installed from that (assuming it would give me the correct version I need for my system)

So after all that (and then some), I'm still getting the same error when I connect to my new job's project in Virtualbox.

Can anyone point me in the right direction of what to do here? This is the first time I've ever worked with Virtualbox, and no one at this company is using Ubuntu, so I'm on my own here.

EDIT: Here is the direct info from running the 2 suggested commands

Inspiron-1750-brick:~ $lscpu
Architecture:          i686
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 23
Stepping:              10
CPU MHz:               2100.000
BogoMIPS:              4189.45
L1d cache:             32K
L1i cache:             32K
L2 cache:              2048K

Inspiron-1750-brick:~ $cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family  : 6
model   : 23
model name  : Intel(R) Core(TM)2 Duo CPU     T6500  @ 2.10GHz
stepping  : 10
microcode : 0xa07
cpu MHz   : 1200.000
cache size  : 2048 KB
physical id : 0
siblings  : 2
core id   : 0
cpu cores : 2
apicid    : 0
initial apicid  : 0
fdiv_bug  : no
hlt_bug   : no
f00f_bug  : no
coma_bug  : no
fpu   : yes
fpu_exception : yes
cpuid level : 13
wp    : yes
flags   : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dtherm
bogomips  : 4189.80
clflush size  : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family  : 6
model   : 23
model name  : Intel(R) Core(TM)2 Duo CPU     T6500  @ 2.10GHz
stepping  : 10
microcode : 0xa07
cpu MHz   : 1200.000
cache size  : 2048 KB
physical id : 0
siblings  : 2
core id   : 1
cpu cores : 2
apicid    : 1
initial apicid  : 1
fdiv_bug  : no
hlt_bug   : no
f00f_bug  : no
coma_bug  : no
fpu   : yes
fpu_exception : yes
cpuid level : 13
wp    : yes
flags   : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dtherm
bogomips  : 4189.45
clflush size  : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:
share|improve this question
    
Please update your question with your CPU model (you can get that info using lscpu or cat /proc/cpuinfo, for example). –  Salem Nov 20 '12 at 18:06
    
possible duplicate : askubuntu.com/questions/41550/… –  Suhaib Nov 20 '12 at 18:12

2 Answers 2

up vote 0 down vote accepted

That error message is just saying that your processor does not support VT-x hardware acceleration or that it is disabled in the BIOS. VT-x hardware acceleration is a feature that some processors have that make virtualization work better and faster, but it is not required to run virtual box, you should be able to run virtualbox (although slower) with 32 bits guests after installing it, even if you are getting that warning.

Again, one posibility is that your processor does indeed support VT-x, but it has it disabled in the BIOS, so If you tell us exactly what processor you have, we might be able to check if it does support VT-x so you can enable it in the BIOS and get full virtualization support.

share|improve this answer
    
Unfortunely, there is no option in BIOS for this Dell that would allow me to enable VT-x. I've linked a pic from the BIOS screen, and there are no options within each tab that allow any Virtualization. Infact, there is nothing in the BIOS menu that even mentions virtualization, VT-x, hardware acceleration, or anything remotely close. imgur.com/PXBvH –  yarhouse Nov 21 '12 at 16:27
    
not all processors support VT-x hardware acceleration, it appears that yours dont. thake a look at this bios which shows the virtualization option silentarchimedes.files.wordpress.com/2008/05/bios.jpg even without virtualization, you should be able to run the virtual machine (although slower than if you had virtualization support) –  Sam Nov 23 '12 at 2:32

There is support for VT-x hardware in VirtualBox (had the same issue with an iso for Suse server). If you have created the VM, select it from the list in VirtualBox then select Settings. Next click on System and the Acceleration tab. Then tick the box 'Enable VT-x/AMD-v' then try and boot

share|improve this answer
    
I am not able to select the Acceleration tab in the System settings. It is grayed out, both with and without the VM running. –  yarhouse Nov 21 '12 at 14:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.