Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying do my notebook's webcam works on Skype 4.1, but I am not having success.

The problem is that the webcam's image appears upside down and with zoom. This problem don't happen on Skype Version 2.1 (Beta). On Skype 2.1 (Beta) my webcam works perfectly.

However, on Skype 4.1 the webcam's image is upside down and with zoom.

I managed to solve only the upside down problem with the following commands:

export LIBV4LCONTROL_FLAGS=3
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

After these commands the webcam's image become normal, but the image is still zoomed.

I could not solve the zoom problem. To work around this I'm obligated to use the both versions (2.1 (beta) and 4.1).

Does anyone know a way to make the image from my webcam stay perfectly normal?

These are the information about my webcam:

  • Bus 002 Device 003: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera

It uses the driver uvcvideo. I'm using the Ubuntu 12.04 64 bits.

share|improve this question
add comment

2 Answers 2

Though I dont have a fix for the zoom problem yet, for the upside down issue I found here (and only here!) a solution that fitted for my case: http://unix.stackexchange.com/questions/62793/skype-webcam-upside-down-but-v4l1compat-missing

I was trying to apply this workaround above (that's widely spread in most of the forums):

export LIBV4LCONTROL_FLAGS=3D
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

but that alone wasn't doing the magic to me, I was getting this error:

ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.

the missing trick, in my case, was first install ia32-libs (sudo apt-get install ia32-libs). Im running Mint 13 x64 with MATE and skype 4.1 for Ubuntu x86.

share|improve this answer
add comment

Hello,

System: Ubuntu 12.04, skype 4.1.0.20

Surely you have checked it, but just in case:

Options > Video devices

There is a check box that says:

Disable Autoexposure (darker video, higher frame rate).

For my case I unchecked it and I could see the remote desktop well.

I hope this helps!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.