Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I use gnome-terminal the background is annoyingly slightly-transparent. Here you can read the ubuntu.stackexchange.com site through the background.

enter image description here

These are the background options I have, which are set to "not transparent".

Options of gt

I have the desktop visual effects set to "Normal". Changing them to None removes the problem, but obviously I lose out on visual effects like window previews, drop shadows, nicer transitions, etc. Any ideas how to make this background truly solid while keeping normal visual effects?

share|improve this question
add comment

3 Answers

up vote 6 down vote accepted

The workaround for this is to set it to transparent and pull the bar to maximum.

That should fix your issue. :)

Like so.

alt text

share|improve this answer
    
:-O I can't believe I didn't try that. I was a radio-button out! –  richq Aug 13 '10 at 20:49
    
@richq its all good bruv! –  myusuf3 Aug 14 '10 at 2:40
add comment

I think this is a bug. Many other people have experienced it too. You can read more about it and find workarounds at https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/561370

share|improve this answer
    
although it really is a bug, the bug you linked does not cover this exact problem. this is the correct bug report bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/549552. it says the problem is fixed, but apparently the fix has not hit the repositories yet. –  lesmana Oct 25 '10 at 10:08
add comment

I'm assuming you encountered this problem with one of the Ubuntu themes. GNOME Terminal will use the background from the theme, and some of the Ubuntu themes (e.g. Ambiance) specify a transparent background for the terminal. You can change this but you need to change a gconf setting which means using gconf-editor (a GUI program) or gconftool (a command line program).

Using gconf-editor, go to /apps/gnome-terminal/profiles/Default/use_theme_background and set it to false.

Alternatively, in a terminal window, type:

gconftool -s /apps/gnome-terminal/profiles/Default/use_theme_background -t bool false

The transparency should disappear.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.