Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been backing up my folders, I am using Seagate Expansion portable Drive. I had created a folder called "|o|o" in the root folder of the portable drive... I copied my latest folders into "|o|o" folder to re-install ubuntu.

When I open the portable drive the folder |o|o is not visible, when I ctrl+a and check properties the space used is 122GB, however when I click on the drive to view properties of the drive used space is 260GB. It looks as if the folder is there in the portable drive but I cannot access it... I have tried to view all the hidden files and "|o|o" is still not there. I am using 12.04.Can you please help me to retrieve this folder.

share|improve this question
|o|o? How did you make that folder? Since | is een restricted character (used for piping commands). And did you check from command line or from a file browser? If only the latter do the 1st too :) Do you know a file name inside that folder? If so... cd to the disc and use find . -name {file_name} -print to search for it from that directory. – Rinzwind Nov 20 '12 at 14:16
@Rinzwind I right clicked and created new folder named it |o|o, I have checked from command line and file browser and the folder is not there. when running the command you gave it does not return anything it just moves to a new line. I have tried it with different file names. – Hans Nov 20 '12 at 14:42
@Rinzwind: | isn't a restricted character. Only / and \0 are. It's quite easy to use pipes in filenames, especially if you're using a GUI instead of the command line. – Scott Severance Nov 21 '12 at 4:42
Yes it is @ScottSeverance Try to do a mkdir |o|o in command line. Won't work because of the use of a special character. | is for piping commands. Hence I was wondering if it might be related. Well from another standpoint: I myself would -never- -ever- consider to use a | in a filename ;) – Rinzwind Nov 21 '12 at 5:49
Actually, it works just fine if you escape it properly. mkdir \|o\|o works just fine. Try it. Of course, files with such names can be inconvenient to use with some command line tools, but my personal philosophy is to use any character that enhances a file name's human readability without regard to command line tools (except when I'm programming) and let the tools cope with the names. After many years of such a philosophy, I've yet to experience a significant problem. The name currently under discussion wouldn't fit my philosophy, however, as its meaning is rather opaque. – Scott Severance Nov 21 '12 at 13:08
up vote 0 down vote accepted

This should work from your OS, just ignore the part about the live cd. it will work since its on your external HDD.

share|improve this answer
Thank you penner, I used Testdisk to recover the hard drive. It ran for over 24 hours. – Hans Nov 23 '12 at 9:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.