Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to set up GNOME Classic (on Ubuntu 12.04.1) to be my default desktop, I can install it without issue and I know how to change to it at the login screen.

The problem I have is when I reboot, the login screen defaults back to Unity for login, is there away to set GNOME Classic to be the default (without removing unity)?

I have installed and configuring as follows but it always defaults to unity

apt-get install gnome-session-fallback indicator-applet-appmenu gnome-tweak-tool

and enable

/usr/lib/lightdm/lightdm-set-defaults -s gnome-classic

Also have the following in /etc/lightdm/lightdm.conf

[SeatDefaults]
user-session=gnome-classic
greeter-session=unity-greeter
greeter-show-manual-login = true
allow-guest=false
share|improve this question
add comment

1 Answer

It's so strange that what you have done didn't solve your problem since it must do that.

Anyway you can try to edit the .dmrc in your home.It looks like

[Desktop]
Session=ubuntu

For GNOME Classic you can change it to say:

[Desktop]
Session=gnome-classic
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.