Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently updated my Ubuntu (10.04 LTS) server (apt-get update, apt-get upgrade), and everything works fine, apart from the root access to my MySQL database.

phpMyAdmin, CakePHP, and essentially all connections return similar access errors. For example, PMA returns 'Connection for controluser as defined in your configuration failed.'

I have tried to find similar examples of this instance, but cannot find assistance in what configuration I should be changing to restore root log in access. The same issue has occurred on two servers. One has additional users so I could get around it, but the other is a new development server with only root MySQL access, so I am stuck on how to resolve this.

share|improve this question
add comment

1 Answer

I eventually figured out the error was the write access level for the my.cnf file for MySQL. Changing this to 644 and restarting MySQL fixed it up.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.