Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Where do I report bugs/problems with Valve’s Steam?

The steam client won't open nor does it display any error message. I have tried right click > Games. I ran steam steam://open/games command, but the client just does not respond. Removing it with apt-get remove steam, deleting the Steam directory & the .deb file and reinstalling it, did not work either.

This problem only occurred after I used killall to force quit it, it was working fine before.

I'm running 12.10 on a 64bit laptop with no additional drivers installed.

Anyone else have this problem and a possible workaround?

Thank you

share|improve this question

marked as duplicate by fossfreedom Jan 6 '13 at 11:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Steam is currently in a limited beta - you will probably have more luck resolving this by reporting it on the steam community for linux forums. – ImaginaryRobots Nov 21 '12 at 16:20

Found a solution on the Steam forum, post #55, solution described below:

This was done on a laptop with Intel HD graphics, not sure if this will work with NVidia or AMD drivers.

1.) Purge Steam PPA sudo apt-get --purge remove steam:i386

2.) Delete all Steam files from /home, including the two .steam files

3.) Download and install wget and sudo dpkg -i steam.deb && sudo apt-get install -f

4.) It should update and install Steam now, enter your username and password. Steam is going to tell you that you are not a beta tester and quit the application.

5.) Run in terminal steam steam://open/games

6.) Steam client should be up and running

share|improve this answer

I do also have this issue. Steam wont start...

I removed the Steam dir from home and tried to start it from a terminal. It wanted to install jockey-common and nvidia-common. Try installing them and try again.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.