Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I see here that, in order to add as custom action in Thunar the search with gnome-search-tool, the command is:

gnome-search-tool –path=%f

and with catfish it is different:

catfish --fileman=thunar --path=%f

(Why the difference, by the way?)

What's the one for Searchmonkey?

(The above do not seem to work for it.)

share|improve this question
up vote 1 down vote accepted

With gnome-search-tool and catfish, command-line options are available and so the programs can integrate into Thunar quite nicely; the --path=%f option is important as that means the location of the selected folder (with its files) can be passed on to these search tools so they open at the right folder.

If you enter the name of the program and then add--help, you will see all the command-line options for these two search tools: for gnome-search-tool --help we have many options such as:

 --named=STRING                  Set the text of "Name contains" search option
 --path=PATH                     Set the text of "Look in folder" search option

With catfish there are similar options, but it used to be essential to specify --fileman=thunar in addition to --path=%f. This was found to be necessary as catfish used to only open the home folder, not the one selected if the fileman workaround was not used. However, it works now with just --path=%f with Catfish 0.3.2 and Thunar 1.2.3 on Xubuntu 12.04.

It doesn't seem to be possible to pass any command-line options to searchmonkey, and there doesn't seem to be any information available: the mailing-lists and forums seem pretty empty. Even if you set the filemanager and options in searchmonkey > settings > preferences > systemcalls, and then specify options in the custom action, it doesn't seem to integrate into Thunar successfully.

Searchmonkey doesn't seem to integrate with other filemanagers either after testing, so it must be because it does not accept any suitable command-line options. The only way to make it integrate would be to create a patch for it and recompile it, which is probably not really worthwhile considering how useful catfish is.

share|improve this answer
does that mean that a script like in your answer for wine programs ( is also out of discussion here? – cipricus Nov 28 '12 at 13:20
@cipricus I tried using a script to see if that would act as a workaround, but searchmonkey still didn't open at the selected folder, but only at /home/mike. – user76204 Nov 28 '12 at 13:21
that's it then. thank you. – cipricus Nov 28 '12 at 13:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.