Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a new user in this forum, even though I have been a part time user of Ubuntu for the last few years, I've noticed that there are some brands like HP, DELL, LENOVO, etc; that seem to be more friendly towards Ubuntu.

In this case I have a Sony Vaio VPCEG15FX, I have been trying to install Ubuntu since 2011, but the same problem occurs with the screen, I am unable to control the Brightness using the laptop Hot keys.

Until two days ago I was able to control the screen brightness with a specific Instruction (Among so many different options that I found but never worked), which I used according to what I read in one post (Can't adjust brightness in a sony vaio T13 ultrabook), as follows :

echo 1000 > /sys/class/backlight/intel_backlight/brightness

Which I entered in the folowing file : /etc/rc.local.

I have read different posts, different solutions, scripts, etc.; I don't know if I am the only Sony vaio user of this specific Model with this problem, but I would like to be able to use the Hot Keys (FN + F5 : FN + F6), and at the same time I would really appreciate if Someone can explain step by step (Clearly , Not in a Cryptic way) what to do in order to make this Laptop to work 100 % with Ubuntu.

Thanks a lot in advance for your time and patience.

share|improve this question
add comment

3 Answers 3

For everyone with a similar problem, Moderator TOZ found a solution for my problem in the following thread :

http://ubuntuforums.org/showthread.php?t=2086359

Thanks everyone for your time and attention.

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Nov 24 '12 at 9:30
add comment

Just connect your system with internet when you open UBUNTU and open 'Additional Drivers' application. Then it automatically shows the available graphics drivers for your system. You can install from there and that's fine. Now by the Hot Keys (FN + F5 : FN + F6) you can manage your system brightness.

share|improve this answer
    
Hello there ! Thanks a lot for your help, but Certainly that's the first option, which Never worked. It always shows that there are No drivers available. The wireless card worked after doing all updates and upgrades, it never worked using the additional drivers tool. I have seen tutorials using scripts and files for acpi events, but they did not work for me either. Thanks for you help. –  martzp Nov 20 '12 at 8:22
add comment
  1. try the following commands

    $ sudo gedit /etc/X11/xorg.conf
    
  2. you will be prompted for password, enter your user account password.

  3. A xorg.conf file will be opened with following contents

Section "Device"

Identifier  "Default Device"

Option  "NoLogo"    "True"

EndSection

  1. Add the following line within the section.

Section "Device"

Identifier  "Default Device"

Option  "NoLogo"    "True"

    Option "RegistryDwords" "EnableBrightnessControl=1"

EndSection

  1. just save it and close.

  2. Enter the following command.

    $ sudo gedit /etc/default/grub

  3. Similarly enter the password as before & a file will be opened, find the lines below

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" GRUB_CMDLINE_LINUX="Linux"

  4. change it to the following

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=video" GRUB_CMDLINE_LINUX="Linux"

  5. save and close it.

  6. Then update the grub with the following command

    $ sudo update-grub

  7. Reboot your system, this will work. I resolved for my nvidia supported vaio VPCEH28FN

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.