Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
How do I get my Broadcom BCM4313 working correctly?

Just installed a fresh Ubuntu 12.10 64bit on my laptop, run the update manager, restarted and suddenly I can't use my wifi anymore.

Ubuntu software center installed automatically the wifi additional driver as you can see in my screenshot.

Additional drivers and wifi issue

If I mark the option "Do not use the device" and apply changes, restarting Ubuntu my wifi is back and I can use it.

If I run iwconfig my terminal is showing this iwconfig

Now if I use Ubuntu for more than 20 minutes surfing the web my wifi it keeps to be connected but I don't receive any signal from it. Any page I try to open it simply don't open (just waiting icon). If I disconnect my wifi and connect it again, same issue, it doesn't work. The only way to make it work again is to restart Ubuntu. And the same story it happens again after aprox. 20, 30 minutes.

WIFI device details: 03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)



share|improve this question

marked as duplicate by Jorge Castro, stephenmyall, Ringtail, hhlp, belacqua Nov 21 '12 at 17:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Please add your device details from the terminal command lspci -nn. – chili555 Nov 20 '12 at 13:06
Added the device details! – Dave Nov 20 '12 at 22:47


I run this one using wired:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

and after a restart the wifi additional driver is actived and working enter image description here

If my wifi will disconnect again I'll let you know.

share|improve this answer
Thank you Dave.. this got my Aspire 5750 (Ubuntu 12.10 64bit)´s wifi up and running again :) I did not even have to restart!! – Voidcode Nov 21 '12 at 3:21
if there's no option to connect via LAN, you can reboot using the previous kernel, wifi will work – bohdan_trotsenko Mar 15 '13 at 20:17

When you start and your wireless is not working, check to see if the correct module is loaded:

    lsmod | grep wl

If it is not listed, load it:

    sudo modprobe wl

Does your wireless spring to life? If so, let's get it to load automagically:

    sudo su
    echo wl >> /etc/modules

Now does your wireless start as expected on boot?

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.