Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have several programs that reuquire 32 bit packages (pointing to the ia32-lib package). However, when I try to install it, this happens.

spirit@ubuntu:~$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch but it is not installable
E: Unable to correct problems, you have held broken packages.

No big whoop, packages die all the time. I tried a month later however and I still got this error, trying to install the specific package produces this error.

spirit@ubuntu:~$ sudo apt-get install ia32-libs-multiarch
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ia32-libs-multiarch is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ia32-libs-multiarch' has no installation candidate

I am no Linux whizz-kid, but this seems to be that the package doesn't exist. I searched for Skype in the software centre (I was told this installs the 32-bit packages) and it does not appear in the software centre, and the downloadable from their website produces an error about - funnily enough - no 32-bit packages.

Anyone who helps me will get a medal from the gods with the weight of a thousand planets. Just don't wear it for god's sake.

share|improve this question
    
Did you install a 64-bit (amd64) Ubuntu or a 32-bit (i386) version? You can also see from uname -a in a terminal. –  Takkat Nov 19 '12 at 21:33
    
I installed a 64 bit version of Ubuntu, as every time I install via Wubi it will always grab the amd64. I'm not sure if it is worth getting the 32-bit version instead since the 64 bit has a few compatibility problems especially like this. –  A British Person Nov 20 '12 at 7:27
    
Nevermind, clearly this is just one of those hard to fix problems that comes with every release (usually it is hardware related, software is new to me). I'll just install a 32-bit version instead. I hope a solution is found soon for all those with 64-bit, I believe in you folk! –  A British Person Nov 22 '12 at 21:26
    
Sounds very much like you don't have an i386 foreign architecture. What's the output of dpkg --print-foreign-architectures ? –  tumbleweed Nov 23 '12 at 11:48
add comment

5 Answers

up vote 11 down vote accepted

Sounds like installing through WUBI did not correctly detect the available foreign architectures. As tumbleweed suggested printing the foreign architectures probably returns nothing. Add i386 as a foreign architecture, update the apt cache, then install the 32 bit libs.

sudo dpkg --add-architecture i386 && sudo apt-get update && sudo apt-get install ia32-libs
share|improve this answer
2  
This worked for me. So many other stupid people out there trying to answer this question - they all have it wrong. so many people keep talking about skype too. Some people just need ia32libs, not skype LOL. –  Jason Feb 16 '13 at 2:59
2  
Sadly this does not work on 13.10. Any workaround? –  phunehehe Oct 27 '13 at 7:08
    
This worked for me on Crunchbang 3.2.0-4. Thanks! –  pdoherty926 Jan 11 at 22:40
add comment

Scotty's answer works great for 12.10, but if you are on 12.04, then dpkg does not support --add-architecture. Just try:

sudo apt-get update

and then try installing ia32-libs as

sudo apt-get install ia32-libs

But it is probably better to install the meta package ia32-libs-multiarch instead.

share|improve this answer
add comment
  • Install Synaptic from terminal window

    sudo apt-get install synaptic
    
  • Launch Synaptic and goto “settings > Repositories”

  • Click “other software > add”
  • Insert this line in the box deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse
  • Click ok and close Synaptic
  • In terminal sudo apt-get update
  • In terminal sudo apt-get install ia32-libs
  • Fresh Install
share|improve this answer
add comment

Have you tried to install them from the Ubuntu Software Center? It should locate us directly the package we're looking for. Search for "ia32", locate ia32-libs-multiarch:i386 and ia32-libs and install them.

ia32-libs-multiarch:i386

If that doesn't solve the problem, try changing the server from Edit > Software Sources and run update from Update Manager or sudo apt-get-update before trying to install again.

share|improve this answer
add comment

If you are having this problem, it's most likely you are on Precise 64-bit with Amazon EC2. They have fixed this for Ubuntu 12.10.

share|improve this answer
    
Same happens with Azure Ubuntu 13 VMs –  pollirrata May 10 '13 at 18:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.