Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When trying to Activate, Broadcom B43legacy wireless driver I get the following error,

SystemError: installArchives() failed.

Please help.

share|improve this question

3 Answers 3

I've found these bug reports:

You can install the driver manually by installing package firmware-b43legacy-installer

share|improve this answer
    
thank you! I had to go to synaptic and totally remove the old firmware-b43legacy-installer, then re-download it to make it work, but I'm now on line wireless to post this comment =) many thanks this is on a 12" powerbook g4 ppc chip –  user10496 Feb 9 '11 at 19:43

I got this error as well when I ran Ubuntu from the install cd. Turns out the cd had an error on it. Just burned a new one and everything was ok ;) So if you're getting the error while running from the cd, you might want to try burning a new one!

share|improve this answer
    
Thanks, trying this on a full install not the CD. I also have read the bug reports and try installing through the terminal. Get another error: sub-process /usr/bin/dpkg returned an error code (1) I noticed in 11.04 alpha that it is nit even offered in Additional Drivers. May it is no longer supported? –  Lyle Feb 9 '11 at 19:44

I had this problem on Ubuntu 10.04 LTS (Lucid Lynx).

$ uname -a
Linux laptop 2.6.38-13-generic #57~lucid1-Ubuntu SMP Tue Mar 6 19:39:06 UTC 2012 i686 GNU/Linux

Looking around they recommended installing bcmwl-kernel-source but that didn't help, as at some point it failed to install (didn't found linux/autoconf.h).

The solution was to install bcmwl-kernel-source and bcmwl-modaliases from the deb package. You can download the deb package for i386 architecture from Launchpad.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.