Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Currently, I am using the Unity Qt panel in my Gnome desktop, and when I press the Windows key, the Unity's dash launches, and I can't use any compiz based shortcuts.

Same behaviour is exhibited when I log in to Unity 2D as well, as the Windows key launches the dash.

I have no desire to change my Compiz shortcuts, so is there any way to change the keyboard mapping of Unity 2D's dash to something other or disable this shortcut completely?

share|improve this question
add comment

5 Answers 5

up vote 8 down vote accepted

You can disable the super key using the command:

gconftool --set /desktop/unity/launcher/super_key_enable --type=bool 0

(Since GNOME 3 settings are in dconf instead of gconf, and unity became a plugin. The method thus became: dconf write /org/compiz/profiles/unity/plugins/unityshell/show-launcher '""')

Then you can define a keyboard shortcut with your preferred method to launch the following command:

dbus-send --type=method_call --dest=com.canonical.Unity2d /Dash com.canonical.Unity2d.Dash.activateHome

This will trigger Unity Home Dash

share|improve this answer
4  
I mapped it to <caps_locks> –  the brx in the walls Feb 17 '11 at 14:46
1  
That launch command didn't work for me, I had to use --dest=com.canonical.Unity2d.Dash when using the daily build for Unity 2D. –  Adam Lindberg Nov 24 '11 at 13:21
    
I guess this method doesn't work anymore in 12.04? –  akaihola May 11 '12 at 9:14
    
Unity 2d is not available anymore. How to open a specific lens using dbus in unity 3d? –  Khurshid Alam Nov 18 '13 at 14:03
add comment

I just installed Ubuntu 11.04 and I was able to use gconf-editor to change the shortcut key.

Make sure you're not running gnome-do! (If it's set to use your key combo, the Dash won't be able to bind to those keys.)

Open a terminal and run gconf-editor

Navigate to this key:

/apps/compiz-1/plugins/unityshell/screen0/options/show_launcher

Modify the show_launcher key to a single key value.

The key in gconf-editor

I set the value to <Super>space and now Super+space opens the dash instead of Super. Note that if you use a key combo, it seems to take a minute before you can use that to invoke the Dash. You also need to complete the key combo quickly.


If you want a more user-friendly interface, you can use the command line:

gconftool --set /apps/compiz-1/plugins/unityshell/screen0/options/show_launcher --type=string "<Super>space"

Or use compizconfig-settings-manager Install compizconfig-settings-manager: In the Desktop section, select Ubuntu Unity Plugin. Set Key to show the launcher to be your desired keys. Again, it takes a minute before you can invoke the Dash.

share|improve this answer
1  
Oh man you just saved me from suicide :) Thanks. –  offby1 Apr 21 '12 at 22:46
    
Great! Just tried the gconftool command in Ubuntu 12.04.1. Works like a charm! –  joelpet Sep 25 '12 at 8:14
    
I just realized that Super+Tab already activates the launcher in a nice way. Thus, I simply reset the show_launcher value to "". –  joelpet Sep 25 '12 at 21:58
add comment

It is not planned for now to make it configurable though it is planned to deactivate that shortcut by default, see bug #705076

share|improve this answer
add comment

Run (Alt+F2 or Synapse) gconf-editor. Navigate to Desktop>Unity>Launcher. Uncheck the box for super_key_enable.

share|improve this answer
1  
You should improve your answer by adding more details or screenshots to help take this from "an answer" to an "awesome answer" –  Marco Ceppi Feb 6 '11 at 21:48
add comment

For Unity-2D in Ubuntu 12.04, the following command worked for me:

dconf write /com/canonical/unity-2d/launcher/super-key-enable false    

see http://wtanaka.com/node/8025

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.